Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am experiencing trouble with Worms Armageddon on Windows 7; the program crashes after launch. The game runs perfectly under Windows XP. Launching the game in compatibility mode does not help. How can I play the game?

share|improve this question
    
Does it crash on the introduction screen? –  Harpal Oct 29 '11 at 18:13
    
Could you provide more information on the specific issue you are seeing when you try to run the game? Any messages? Anything in the event log? Also, where did you get your copy of the game? Is it a physical disc? Something else? –  Aubergine Oct 29 '11 at 18:24
    
It shows black screen as if the game is going to launch, then after some blinking an error message appears saying "The program has stopped working". –  Grigor Gevorgyan Oct 29 '11 at 19:49
    
Have you tried updating the game with the latest patch? –  Harpal Oct 29 '11 at 20:28
add comment

4 Answers

Make sure you are running the latest version (currently v3.7.2.1).

Notice how they mention Windows 2000 support on the updates page linked below. As WA is a game released in 1999 where the NT family wasn't popular yet, it is bound to have many issues on those OS'es unpatched.

Also, kudos to Team17 for releasing patches 13 years after initial release.

http://wormsarmageddon.team17.com/main.html?page=supp&area=upda

share|improve this answer
    
This worked for me after setting WA.exe to Run as Administrator and Run in compatibility mode for Windows XP, SP3 –  WOUNDEDStevenJones Mar 24 at 20:55
add comment

Going on the assumption the game crashes at launch and therefore the inroduction screen, disabling the introduction screen might solve your problem, to do this:

right-click the WA shortcut icon, select properties, and in the "Target" text box, type "/nointro" at the end of the path.

This must be outside of the quotation marks for it to work. For example:

"C:\Worms Armageddon\wa.exe" /nointro

share|improve this answer
    
Tried, still "WA.exe has stopped working"... –  Grigor Gevorgyan Oct 29 '11 at 19:52
add comment

Easy solution.

  1. Download VMware
  2. Open VMware and install Windows XP on it
  3. Put your Worms Armageddon CD in and install
  4. Play and enjoy :)
share|improve this answer
    
That assumes that he has the spare processing power / RAM to fully run VMWare in a state that won't be laggy in running a game...even an older one such as this. –  espais Dec 17 '12 at 3:25
    
It also assumes you have a spare Windows XP product key. It makes the solution a bit expensive. –  Gnoupi Dec 17 '12 at 8:34
    
You can enable Direct3D acceleration in the VMWare guest, if both host and guest will be Windows. –  deed02392 Feb 15 '13 at 18:58
add comment

I had similar issues. These are the things I needed to do to get it running:

  • In the Worms folder, find WA.exe and Right-Click->Properties
  • Set Run as Administrator
  • Set Run in compatibility mode for Windows XP, SP3
  • Apply and OK
  • In the same folder as WA.exe, Right-Click->New->Text Document
  • Paste in the following:

@echo off
TASKKILL /IM explorer.exe /F
start /B /I /WAIT WA.exe
start explorer.exe

  • Save as Worms.bat (Make sure the file type is set to All files, not Text Document)
  • Create a shortcut to this bat file on your desktop or something.

If you don't like the command prompt window showing up, you can run the bat file from within a powershell script. See my edit to PaN1C_Showt1Me's answer on this question. To summarise:

  • Create another file (with a .vbs extension) and paste:

Set WshShell = CreateObject("WScript.Shell")
WshShell.Run chr(34) & "Worms.bat" & Chr(34), 0
Set WshShell = Nothing

  • Run this file instead of the bat file
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.