Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My son's DS won't power up when the button is pushed. It worked fine up until now, but it is about 5 years old. We have tried charging it (with several chargers in case that is the issue) and there is no lights/no response. Can it be fixed?

share|improve this question
add comment

2 Answers

up vote 8 down vote accepted

Since a power failure can be caused for many reasons, it tough to say for sure. There are two fuses in these guys, and it's possible that one of them has been blown. There are instructions to remove and short-cut the fuse with a piece of wire here. Alternatively, you can purchase replacement fuses online.

If it's the system's power supply or other failed component, you're better off buying a new one. While these aren't very repairable, their low-cost makes them relatively replaceable.

share|improve this answer
add comment

It could just be a broken battery. Do you know anyone with a working DS? If so, remove their good battery and try it out in yours (they're simple to swap, you just need a small screwdriver). New replacement DS batteries are cheap to buy. Good luck :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.