Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have problem my license SC2 license does not show up when I log into my account on battle.net. The strange thing is that I have it only at website - when I log into my SC2 account in the game everything is fine. What's going on?

Here is a screenshot from the website.

share|improve this question
    
hmm, do you see the screen? ok if you don't see it the info is just: "xxx, No starcraft2 license found" –  com Nov 9 '11 at 11:17

1 Answer 1

up vote 3 down vote accepted

as far as i can see from other people on the internet this mostly happens when they go to the wrong region(such as going to US instead of EU), have you made sure that the battle.net page is the one for your region?

This can also happen if you have multiple starcraft 2 accounts on same email, then you need to migrate one or contact blizzard support.

If non of this things are your problem you can try this

When I login, I receive the message, "NO STARCRAFT II LICENSE FOUND", and I cannot post.

Simply try logging in and logging back out. If that does not work, you'll need to flush your account cache. To do this, change something on your account: your password, e-mail, address, etc. Changing anything will reset your account cache.

share|improve this answer
    
Thank's! I was going to US but i have account on EU. –  com Nov 9 '11 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.