Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Because my C: drive is just a 40gig SSD and space is an issue with it, I tend to keep games from saving files, DLC and screenshots there.

I've changed my 'Documents' target on Windows 7 to target a folder on my D: drive. However, Sims 3 doesn't seem to care about this and keeps creating files at Username\My Documents on my C: drive.

Could anyone tell me if its possible, and how I can get it to download store content, save screenshots, save games, etc., in a folder on my D: drive and not there?

share|improve this question
    
Not sure if it would anything, but did you buy the CD version, or did you download your game from Steam or Origin? –  Kareen Nov 9 '11 at 21:20
    
How exactly did you "change the Documents target" without making a link? –  kotekzot Aug 5 '12 at 17:50

3 Answers 3

I'm guessing the game has been hard coded to use C:\ instead of checking where the documents directory is, you could use a NTFS Symbolic Link to workaround it. This will essentially create a shortcut, that programs will actually follow it properly.

To create one you will need to open a command prompt as admin. To do that just open the Start menu, type "cmd" and press Control + Shift + Enter. From there the basic command your going to want is

mklink /D "C:\Users\[you]\Documents" "D:\Users\[you]\Documents"

Of course supplement the directories for the ones you're using. You can either do it for the entire Documents directory or just for The Sims 3 data. In other words, move the Sims 3 folder, for example, to drive D before entering the above command.

share|improve this answer
    
I try this method but get the following error message: "Cannot create a file when that file already exists." Any idea what's wrong? –  Rok Aug 27 at 10:52
    
I think I figured it out from Jen's answer: You must move the directory from C to D before entering this command."Supplement the directories..." from this answer was not clear enough for me, but the wording in Jen's answer was. Thanks to all those who helped, though. This works. –  Rok Aug 27 at 11:14
    
I'm not having this problem with the Sims yet, but I was planning on installing the Sims 3 on a very similar set up as this guy shortly. In addition, this may be the fix for me with another game I am currently have a problem with. So thank you greatly for fixing this, and Dracs for posting it even if it was almost three years ago. I feel like this may even make a good self-answered question to post for anybody having future problems with separate drives. –  Tylor Aug 27 at 13:48

Hi I had the same problem with installing it into A Drive and then there was still files in C. I came across a website that helped me. Dracs got part of the Symbolic link right but this one works 100% and I've used it.

It is possible if you make a symbolic link.

First move the entire The Sims 3 folder to where you want. For example in D:\Sims3. Do not leave a The Sims 3 folder behind, if it is there the next step will fail.

Next open a command console with admin rights (UAC): 1. Click the Start button 2. Type CMD in the Start Search box 3. Press and hold down [Ctrl]+[Shift]+[Enter]

Type mklink /J "C:\Users\you\Documents\Electronic Arts\The Sims 3" "D:\The Sims 3"

This will make a junction (symbolic hard link) to D:\Sims3 from the original location. It will recreate the folder you moved in the first step, but now as a symbolic link. Think of this as a folder level shortcut.

Windows and all programs will think the files are still in documents, but in reality they will be in D:\Sims3 now.

If you already moved My Documents, use the new path instead of the C:\Users location.

From this thread

share|improve this answer
    
I can confirm that the method above works, but only after moving the directory from C to D, and with double quotes around "D:\Sims3" for example. –  Rok Aug 27 at 11:10

Try uninstalling it then when you re-install it, use the custom download option and set it where you want it to save, unless that's what you mean when you said, "I've changed my 'Documents' target on Windows 7 to target a folder on my D: drive."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.