Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I created an .nethackrc to make nethack fitting my needs with the following line :

OPTIONS=autodig,!autopickup

But even if I disabled autopickup, it is still activated in game and it is very annoying...

I'm running nethack 3.4.3

Any ideas?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Some possibilities:

  • Is your config file in the correct location? You can test that by setting some easily visible option like name and starting a new game to see if it has effect.

  • Do you have a NETHACKOPTIONS environment variable that might be overriding your options?

  • Did you toggle autopickup from the Options menu or press @ by accident while playing?

share|improve this answer
    
My nethack rc is well loaded (I activate color for example and it work, and setted up a custom name for my dog), but this option still activated. echo $NETHACKOPTIONS returns nothing. And I think I haven't typed @ (Alt Gr O is a big accident I think...). –  MARTIN Damien Nov 10 '11 at 12:12
4  
@MARTINDamien You've accepted this answer, but also added a comment suggesting none of its suggestions are correct. Is your comment out of date? –  Mark Hurd Dec 2 '11 at 9:57
add comment

Changing the autopickup setting in the rc file only affects new games you start after the change. It does not affect games you load from a previous save file.

The reason for this is that you'll often want to change the autopickup settings during the course of a game without affecting future games. So that setting is saved as part of the save file, so that if you change the setting in-game, it will be remembered if you save the game and later load it again. As a consequence changing the rc file won't have any effect on already saved games.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.