Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have insane mouse lag in Skyrim. I have changed

iPresentInterval=0

in Skyrim.ini file and

bMouseAcceleration=0

in Skyrimprefs.ini

But I still have mouse lag and the game is unplayable. What can I do?

share|improve this question
2  
Are you 100% sure only the mouse is lagging and not the graphics themselves? –  Tom Wijsman Nov 12 '11 at 0:09
    
Is Vsync on or off? –  mordi2k Nov 12 '11 at 0:19
    
@mordi2k "iPreserveInterval" apparently is VSync, so it's off. –  badp Nov 12 '11 at 0:51
1  
update: The iPresentInterval=0 did seem to fix mouse lag in the menus, but not in the game world. –  Kim Nov 12 '11 at 1:14
1  
This answer did it for me: gaming.stackexchange.com/questions/34878/… –  Vaccano Nov 14 '11 at 6:27

2 Answers 2

up vote 3 down vote accepted

I had the same problem that you are experiencing and determined that the source of the problem lies with the mouse (for me anyhow). I have the razor naga, and after turning off acceleration in skyrim and also turning off vsync I experienced the same lag. When i would move the mouse rapidly the game could not keep up. After thinking about it I found that the razor naga had an acceleration of its own and after turning off the mouse acceleration directly at the source of the mouse (razer naga control panel "downloadable driver") the game ran perfectly.

share|improve this answer
    
I have a Razor DeathAdder and am having the same problem how do you turn off mouse acceleration, its the only thing i haven't tried yet. –  user14121 Nov 13 '11 at 2:42
    
If you do not already have the mouse driver installed you must do so. Upon doing this you can click the razor symbol in the bottom right of your screen. There is a check box under the performance section that says enable acceleration. Make sure that this is NOT checked. Also note that this is only part of the problem and you must also turn off vsync and the ingame acceleration. –  Killuario Nov 13 '11 at 6:44

There are two fixes for mouse lag. There's the one you mentioned, which you should use. There's also this one:

Disable mouse smoothing

  • Go to your Steam Directory, then steamapps, common, skyrim and select Skyrim again.
  • Create a backup of the SkyrimPrefs.ini file.
  • Open the file, then scroll down to where it says [Controls] and find bMouseAcceleration=1.
  • Change to bMouseAcceleration=0.
  • Save, exit, and play.

This fix and the two below are from Skyrim Reddit, and are credited to “Dead man posting” on the Something Awful Forums.

Using both of these worked well for me.

source: http://www.pcgamer.com/2011/11/11/the-elder-scrolls-v-skyrim-tweaks-improve-graphics-disable-vsync-change-fov-and-more/

share|improve this answer
    
i tried that aswell but the character in game is still around 500ms behind in every movement i do with the mouse –  Kim Nov 12 '11 at 11:43

protected by Community Nov 13 '11 at 2:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.