Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When using Alt+Tab, I can't seem to get back to Skyrim. Clicking it's icon or Alt+Tab to get back, I just see an empty window. Windowed mode doesn't allow me to use it in a Windowed (Fullscreen) manner like seen with other games, so that doesn't seem to be an option either.

Is there any way to fix this behavior?

share|improve this question
2  
Sadly fullscreen windowed, without borders isn't supported in enough games... you'd think it'd be standard. –  WernerCD Nov 12 '11 at 20:35
1  
There are mods for windowed fullscreen. –  SevenSidedDie Oct 16 '12 at 2:09

11 Answers 11

up vote 17 down vote accepted

When you get to the empty window, Alt+Tab to the Skyrim window again. This will bring you back to the game.

Alternatively, you can use Ctrl+Shift+Esc to open the Task Manager, right click the Skyrim entry in the Applications tab, and select Bring to Front.

share|improve this answer
    
Seems the fastest way is to press Alt+Tab thrice. Thanks! –  Tom Wijsman Nov 12 '11 at 15:47
    
When using the "alt-tab again" method, Skyrim will occasionally crash to desktop. Make sure you save before alt-tabbing out! –  Ben Blank Nov 13 '11 at 7:59
2  
@BenBlank: I've only had that occur once; but indeed, one should be quick saving using F5 often anyway. It's really a pain to travel a long distance and then to suddenly run into a situation were you die. Also, it's possible to run Skyrim in Windowed (Fullscreen) mode using BorderLess.exe to remove the borders and resizing the window using a AutoHotkey/AutoIt script. It might be possible to remove the borders in the script too, I'm going to look into that later on... –  Tom Wijsman Nov 17 '11 at 14:19
    
If you have a decent processor and windows 7, try Alt+Tab, and then Windows key+Tab –  Domocus Nov 19 '11 at 16:44
    
Why does that need a decent processor? –  Hennes Mar 15 at 13:47

I have had to do this before I know one way ALT-TAB out like you did then Press the Windows button (For Win 8 this brings you to the menu) And if you select Desktop again Skyrim will open in full screen.

This works on Windows 8 but I haven't tested it on Windows 7.

share|improve this answer

After you press alt+tab it will bring you to a black screen, right? Just press alt+tab again and choose Skyrim, and it will bring you back. It's just as easy as that with no other programs needed.

share|improve this answer
    
The current accepted answer has already stated this. –  galacticninja Mar 14 '13 at 3:42

I've found that the best way to fix this is by pressing ctrl+alt+delete, pressing 'Cancel', and then trying to re-maximize Skyrim. That works every time for me.

share|improve this answer

Actually, there's a much easier method of getting around this. When going back into the game, when you would normally click the game's window to go back to full-screen, drag the window down an inch or so and it'll go back to full-screen - this will always get rid of the cursor.

share|improve this answer

Here's my updated AutoHotkey script. Run it once, it will set the game fullscreen windowed shortly after it is launched.

#SingleInstance Force
#Persistent
#IfWinActive Skyrim ahk_class Skyrim
{
  SetTimer Exile, 1000
  Return
}

Exile:
  WinGet IDs, List, ahk_class Skyrim
  Screen_X = %A_ScreenWidth%
  Screen_Y = %A_ScreenHeight%
  Loop %IDs%
  {
    ID := IDs%A_Index%
    If ID not in %Old_IDs%
    {
      WinActivate ahk_id %ID%
      WinSet, Style, -0xC40000, A
      WinMove,A,,0,0,Screen_X,Screen_Y
      ;WinActivate, A
    }
    New_IDs .= ID ","
  } 
  StringTrimRight Old_IDs, New_IDs, 1
  New_IDs =
Return

Don't ask me about the loop, I just pieced together parts of various AutoHotkey scripts that worked. The one I used previously worked with a keyboard shortcut and caused problems in Windows. This one should only ever touch the Skyrim window.

The game should first be set to windowed mode, and full desktop dimensions by editing SkyrimPrefs.ini located in ~/Documents/My Games/Skyrim:

bFull Screen=0
iSize H=1440
iSize W=2560

PS: When you alt tab like this, it's very fast but you may get the windows mouse cursor appearing in the game (I think this issue is also with the default fullscreen mode). The quickest fix for me is to press the tilde key, which activates the console. It's easier then going in the game menu, but it's the same principle: pause the game. So toggle console, alt tab, un-toggle console. Should prevent the Windows mouse cursor from appearing. There are also possible solutions with AutoHotkey for the mouse cursor but I haven't tried those yet.

share|improve this answer

I also get a black window with a border, but I've found the solution for it. I.e., Skyrim and Chrome running simultaneously.

  1. Activate Chrome
  2. Press Alt+Tab, choose Skyrim
  3. The Skyrim window will be black/blank
  4. Keep pressing Alt, and scroll to Chrome then back to Skyrim
  5. Release Alt
  6. Skyrim will be running fullscreen again
share|improve this answer

I have found this to always work (for me).

  1. Pause before you alt tab
  2. Alt Tab
  3. Go to Gaming.stackexchange.com and find the answer you want
  4. Click on the Skyrim icon in the task bar. You'll get the black bordered screen.
  5. Alt Tab again, back to gaming.stackexchange.com
  6. Minimise active screen (gaming.stackexchange.com). Then Skyrim will come back up.
  7. Unpause Skyrim
  8. Fun

For some reason it doesn't like getting focus the first time. But the second time its ok.

share|improve this answer

Try the Simple Borderless Window mod. It will make Alt-Tabbing almost instant, though may reduce your framerate. It's similar to the mod mentioned by aearon but doesn't require AutoHotKey to be installed.

share|improve this answer
    
Sorta works for me. Most of the time tab-switching works, but occasionally it has a hard time returning quickly to Skyrim. Once it gave me the doubled cursor after struggling to return to Skyrim, making me think it might have some race conditions when the CPU is overburdened. But, most of the time it works just great. –  SevenSidedDie Oct 11 '13 at 22:38

Another option is this Borderless Windowed Fullscreen mod, but it's going to lower your framerate.

share|improve this answer
    
The SBW mod works perfectlty for me on Windows 7 + ATI 4850. It doesn't lower the frame rate at all. I play 2560x1440 with anti alias off for a stable 30+ FPS, so trust me I've been tweaking my FPS for a while. I suspect this issue is completely outdated, probably related to Windows XP and/or very old graphics cards? This version of SBW works perfectly for me. The EXE is just a compiled Autohotkey script. 100% stable. Just have to fiddle a little bit to set it up and edit the desktop dimensions in your INI file. –  faB Dec 5 '11 at 16:46

Skyrim has an interesting behavior with alt-tabbing. When you alt-tab back, you get that black screen with the borders. Left click the upper left hand corner, which will bring up what appears to be a right click context menu for whatever application you were in when you alt-tabbed back to Skyrim. Once the menu comes up, just click in the black screen area of the Skyrim window and it will bring you back to the application.

This behavior is bizarre and strange. Like has been previously said, it will sometimes crash.

share|improve this answer

protected by z ' Mar 15 at 13:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.