Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When I change a key in Skyrim, upon restart Skyrim it doesn't seem to have remembered that change. This is not the result of crashing, I just properly exit Skyrim from the menu.

Some keys (like J for Journal) are a bit out of reach, while I frequently want to look what quest I have to do next without having to go and press J to get to the quests and the even further M (on Azerty) to get to the maps. There are still some keys available for me in the left half of the keyboard, I would prefer using them instead. But apparently, rebinding the keys only works until I exit Skyrim...

Is there a fix to this bug?

share|improve this question
    
Have you changed your keys and then saved the game? I've changed all my keys and it's kept them, even for a new play through. Maybe the game can't write to the directoy where it's trying to save the game? –  Viper_Sb Nov 12 '11 at 21:40
    
My issue is that when reading books, the game uses my EDSF and the default WSAD at the same time, telling me "E" is take, but actually no key on my keyboard is take, as it won't recognise my change. –  user14243 Nov 14 '11 at 2:50
    
This is the fault of how they set up key aliasing, where only some uses of a key use the (rebindable) alias and others are soft-coded in a certain text file to a specific keycode. There's already a simple mod to fix this on skyrimnexus.com, though I can't access the site right now to give you the exact link. –  SevenSidedDie Nov 14 '11 at 4:11
1  
@derp — Courtesy of StrixVaria, here's a direct link to the mod SevenSidedDie mentions. –  Ben Blank Nov 15 '11 at 1:42
add comment

4 Answers

up vote 3 down vote accepted
  1. Download the TakeOwnership zip from here
  2. Use the installtakeownership.reg
  3. Go to skyrim in your program files.
  4. Right click on the skyrim folder and click on the new take ownership button.

Go remap your keys and see if it saves them now.

share|improve this answer
1  
I know how to take ownership without that file, I'll verify the permissions on that folder with Process Monitor soon. If it are the permissions, you'll get an accept mark. Thanks in advance... :) –  Tom Wijsman Nov 15 '11 at 0:47
2  
Easiest way to explain how for anyone who comes across this later. I had the same problem as you and this is what I did to fix it. o ya also make sure you do a game save after the remap. Hope it helped you. –  IZZO Nov 15 '11 at 6:14
add comment

Right-click the launcher, and 'Run as administrator'. Makes your changes, and exit the game. Next time you enter the game normally, the changes should have stuck. The key-bindings are classed as game files, so they cannot be over-written without admin permissions.

share|improve this answer
add comment

Here is the solution I tried. Someone posted it earlier:

  • Right click on the Icon and "Run as Administrator"
  • Inside the game, Change the settings/control keys
  • Save the game and close it back to the desktop.

When you log back in, the preferences and controls should be saved.

share|improve this answer
add comment

Here's an idea. Run the TESV.exe as administrator. The reason it doesn't save custom controls is because it saves them in a temp file unless it can save your controls into a text file inside the install directory. Here's a link to download mine: http://www.mediafire.com/?wqqnf3knp7ssg03 You should put this in your install directory (where the .exe's are) after you edit all the key values. I don't know of any simple way of fixing the locked interface keys (only displays default) so there are plenty of mods that help with that for now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.