Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

If I walk up close to a door, then walk backwards facing the door, or looking up/down a steep mountainside causes horrible flickering.

This is on an Nvidia GTX580 under windows 7. System is an i7 2600, w/ 16GB Ram.

All the latest drivers.

share|improve this question
    
I'm having this same issue. :/ –  spugsley Nov 12 '11 at 17:16
    
Me too. Especially in the darkness. GTX570, Win7 64bit, latest drivers. –  user14086 Nov 12 '11 at 17:18
    
Thanks @spugsley - that does make it more appropriate, and is ultimately what I want. –  Peter LaComb Jr. Nov 12 '11 at 17:39
    
@Peter - You're welcome, since I'm having the same issue, I want to make sure that you get a good answer :) –  spugsley Nov 12 '11 at 17:42
    
Between the game update and video driver updates, this issue has resolved. –  Peter LaComb Jr. Apr 6 '12 at 13:08
add comment

4 Answers

A lot of people are sharing the same problem. Are you having Shadow flickering or Texture flickering? As for shadow flickering there is no current fix. Texture Flickering is very odd. On my 1st PC just doing a clean install of my video drivers fixed it (GTX580). That means, uninstalling the video card, then downloading lastest drivers. On my other PC, which has a 250 just disabling AA fixed it, here I still get some flickering, but it has been reduced greatly. Give this 2 a try. This website has a nice list of bugs and fixes http://www.gamingreality.com/2011/11/skyrim-fixes-for-bugs-crashes-sound.html

share|improve this answer
add comment

I've magaged to get rid of all the flicker so far. first on the face then on the textures in the water you name it. as soon as I solved one problem another opened. Anyways i fixed it by using the latest amd drivers. first though i deleted atigpud.dll out of the skyrim folder. probably c:\program files(x86)\steam\steamapps\skyrim or something. I myself have it moved to d:\games\skyrim so i can't remember where it installed first.

anyways after deleting that file and/or atiumdag.dll, open the amd vision engine control panel for you're card and select gaming 3d application settings scroll down to the bottom and in the crossfire mode select use AMD Pre-defined Profile. select the profile 3DMark11Demo.exe and then scroll to the top and press save. a box should open allowing you to selct the tesv.exe file in the skyrim folder. confirm it when it asks if you want to overwrite the predifined one. then go to application profiles on the left and pick tesv.exe then select use as current setting.

If you got all that then goodo. if not then sorry you might have to try something else.

share|improve this answer
add comment

I tried playing Skyrim today after patch, and it's still flickering. I have 2x5800 Mobilty Radeon cards and found that I play in windowed mode problem is eliminated. Turning off Crossfire also worked for me but performance hit was too great for me to enjoy the game

I also did this fix I found on a site which seemed to help the initial dragon screen when starting a new game and may well be part of the solution. Paste this on last line under display heading in your Skyrim preferences file, the one in the game folder and not the one in My Documents one:

iPresentInterval=0 
share|improve this answer
add comment

To fix the problem go to windowed mode and switch the resolution to your liking the problem for me is completely fixed I hope this will work for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.