Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I prefer to hold the shift key to run, and so every time I start the game, I hit Caps Lock to disable auto-run. However, I find it always finds opportunities to re-enable itself. Sometimes I will go through a door that has a loading screen, and I'm auto-running when I come out the other site. Other times I will speak to an NPC and will be running after the conversation has ended.

I tried finding an option in the menu but couldn't. Is there some kind of configuration that would allow me to disable auto-run altogether so that the game doesn't do it for me?

share|improve this question
    
Why do you need to push caps lock to disable auto-run in the start? What happens if you change the auto-run key of Skyrim itself? –  Tom Wijsman Nov 14 '11 at 21:15
    
Because the game sets my character to auto-run automatically. I haven't tried changing the key but I presume that the game would still set me on auto-run automatically at every loading. I'll try tonight. –  Xeon06 Nov 14 '11 at 21:24
1  
Man... how can you bear anything but auto run. Perhaps my character has a bad knee, but his walk speed is glacial. –  EBongo Apr 18 '12 at 2:13
    
Yeah, why would anyone want to walk by default? –  oscilatingcretin Oct 13 '12 at 7:29

2 Answers 2

You can change the default autorun state from on to off by editing the game's preference file, which is located in:

My Documents/My games/Skyrim/SkyrimPrefs.ini

In there, you can find the section [Controls] which has a setting

bAlwaysRunByDefault=1

Change it to:

bAlwaysRunByDefault=0

To turn autorun off by default.

share|improve this answer
    
For some reason that had no effect (I restarted the game). I'm thinking this might be a bug. I'll leave the question open to see if anyone else has anything to add and then I'll accept your answer because it should be the answer even though it doesn't seem to work. –  Xeon06 Nov 15 '11 at 2:49
    
Did you exit the game before making the changes and saving the config file? Because it works for me when I do it like that. –  Wes Oldenbeuving Nov 15 '11 at 7:12
    
Yeah, I completely closed the game, modified it, and started it back up. I'll try again tonight, maybe it somehow reverted. –  Xeon06 Nov 15 '11 at 14:45
    
As soon as you do what causes it to glitch it still defaults back to always run –  user19916 Feb 14 '12 at 4:05

The bAlwaysRunByDefault suggestion is useful for when you first start up the game, but the problem isn't what the default is, it's the game toggling your current setting without prompting. This a known issue caused by doing certain things while holding shift. Holding shift while talking to an NPC causes it very consistently. Going through a loading screen does it inconsistently. I've also heard of people experiencing it when getting a killing blow animation.

Edit: Nexus Thread discussing the issue for reference

share|improve this answer

protected by Oak Oct 13 '12 at 11:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.