Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I get the following error while playing Unreal Tournament 2003 on my tablet :

UT2003 Build UT2003_Build_[2002-09-19_17.26]
OS: Windows NT 6.1 (Build: 7600)
CPU: AuthenticAMD Unknown processor @ 1898 MHz with 2047MB RAM
Video: NVIDIA GeForce Go 6150 (9156)
Negative delta time!
UGameEngine::Tick <- UpdateWorld <- MainLoop

How can I prevent it?

share|improve this question
    
Erm, what was the tag for this kind of posts? –  badp Jul 28 '10 at 15:25
    
troubleshooting is fine with me @badp –  jmfsg Jul 28 '10 at 15:27
    
installed the AMD Dual-Core Optimizer, but it doesn't show on the tray in Windows 7 and the error still persists –  iceman Jul 28 '10 at 16:01

2 Answers 2

Negative delta time errors come from Windows misreading your processor speed or not recognizing it. Since this is a game made in 2003, it won't have dual-core support, which is likely the cause of your problem.

If you have a dual-core CPU, this should help. Following this thread on Tom's Hardware, it looks like installing the AMD tool called the AMD Dual-Core Optimizer. This tool will help fix errors caused by a game not using the Windows API for timing. This way of looking for a delta time is confused by dual-cores since there are two processors reporting their clock simultaneously.

If you don't have a dual-core CPU, then the problem gets a little hairier. I would suggest installing the most up-to-date chipset drivers for your system, which might help with this problem. Also, make sure Windows is up-to-date, as there may have been a hotfix that prevents this from happening.

share|improve this answer
    
i've my tablet PC info, can you give more specific tips –  iceman Jul 28 '10 at 15:47
    
If you give your information, I can see about tailoring an answer to your computer specs ... –  Michael Herold Jul 28 '10 at 15:54
    
just added it in the post as well : h10025.www1.hp.com/ewfrf/wc/… –  iceman Jul 28 '10 at 15:57

Running dual core optimizer will only help applications which are meant to run single-threaded benefit from both cores, but never be able to use both, only the utilization of both cores are kept in balance.

I guess the solution to your problem is the following:

(Quoting from http://hardanswers.net/unreal-tournament-dual-core)

  1. Right click on the main game application. The location of this will vary from game to game. (..)* For Unreal Tournament 2003, this will be called UT2003.exe, (..)
  2. Choose the Properties option.
  3. Click on the Compatibility tab on the menu that appears.
  4. Put a check mark in Run this program in compatibility mode.
  5. In the drop box underneath choose Windows 98/Windows ME.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.