Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm trying to play Skyrim on my secondary monitor (dual monitor setup). Short of changing my primary monitor, is there any way to force it to open there? (I play in fullscreen). My initial guess was that simply changing the graphics adapter would do the trick - but it didn't. I'm using Windows 7.

share|improve this question
    
The question is: why is there an option to select multiple Graphic cards in the option dialogs (in my case, two entries for Radeon 6870, one for each display surface?), if the game does not make use of that setting? Just another bug? –  user16385 Dec 13 '11 at 9:01
    
If you have an AMD card, you could try to set the application to prefer the second monitor via Hydravision. Then set to windowed mode, move it to second monitor, set resolution, then set back to full-screen mode. –  DrFish Dec 13 '11 at 12:03
    

3 Answers 3

up vote 3 down vote accepted

Your best bet is probably going to be to run the game in Borderless Windowed mode. There are a number of mods and scripts to force the game to do this.

This is the most popular one and was recommended when the question was asked here at Gaming.SE, but comments indicate it's having problems after the latest patch - presumably due to Bethesda changing the way the games executable interacts with Steam.

This alternative provides a script for the free, popular AutoHotKey utility which claims to resize the window.

As always, YMMV as to the stability of the game with either of these options, especially this soon after release, while the game is still being very actively patched.

share|improve this answer
    
Thanks - I'll look into those. –  guywhoneedsahand Nov 22 '11 at 1:22

In a post on the Nexus forum, a user suggests changing which monitor is your "primary":

I have a set up with a 22" LCD and a 32" TV linked up to the same Nvidia card, running in dual screen. I just set the primary monitor to the TV and so all games default to that. Picking the right resolution in a lot of slightly older games is a real pain, but most of the time it's workable. I would suggest you just set the other screen to be your primary, and change it back again afterwards, that should work.

share|improve this answer
    
I've done this and it works quite well. Windows has no qualms about moving the taskbar to the "secondary" monitor and non-games can be dragged around easily enough (and typically remember where they were when you close and reopen them). I've found no real downside to this setup. –  Ben Blank Nov 25 '11 at 18:50

Sorry to bring up an old post, I write this only so if anyone else has this problem in the future at least the answer is out here, I found that the problem happens when two lines are not in both the Skyrim.ini and the SkyrimPrefs.ini and those lines are:


iAdapter=1
sD3DDevice="Your Graphic Card Name Goes Here"

normally they will be in the SkyrimPrefs.ini but not in the Skyrim.ini so just copy them over and your game will launch on your second monitor like you want. They go under the [Display]


iAdapter=0 "Default Monitor"
iAdapter=1 "Second Monitor"
iAdapter=2 "Third Monitor"

and so on

Hope this Helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.