Sign up ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I want to solve the "Missing in Action"-quest non-violently. It's said that I need an Legionaire Imperial armor set, my selfcrafted Imperial one failed. But where to get the items?

share|improve this question
Kill an Imperial Legionaire from one of the warcamps / random encounters? – Raven Dreamer Nov 23 '11 at 3:54
@Raven Not very non-violently :) I want to buy, earn, or find it laying around somewhere. Stealthy stealing also may be an option as a last resort. But I do not want to aggressively attack someone who has no beef with me. – k0pernikus Nov 23 '11 at 9:53
Besides, I went to an Imperial camp, killed one of the guards, took his armor but still nu luck with the guards of the Missing in Action quest. I also tried killing everyone in the camp to see if I could get the Legate's armor set, but no such luck. – Zsub Dec 2 '11 at 8:48

4 Answers 4

up vote 5 down vote accepted

You can't. The linked answer is incorrect; such armor does not exist.

It's actually not possible to complete this quest peacefully. There is an Imperial Decree that is not available without the use of the console that appears to be the key to this quest, but it was apparently excluded from the game as the result of a bug or some other unknown reason. Not only is it not present in the actual game, but the console-obtained version doesn't do anything.

Source: UESP Quest Page

share|improve this answer

The strategy guide says that there are 3 options.

  1. You kill everyone and rescue Thorald.
  2. You bring Avulstein Gray-Mane with you and kill everyone and rescue Thorald.
  3. You stealthily sneak into the Keep through the north side door that is a master lock.
share|improve this answer
I just realized that the Prima Guide is really bad and doesn't have the correct answers because they didn't have enough time with the game. – Precog DragonBorn Nov 23 '11 at 0:35
I've never had a good experience with the Prima Guides. – normanthesquid Nov 23 '11 at 15:00
Actually this answer is correct. There is no such armor in game, so these are your only three options. – agf Dec 8 '11 at 11:38
There absolutely is armor called Imperial Legionnaires Armor, and I have read somewhere that it's the kind of armor you need to talk the Thalmor at Northwatch Keep to let Thorald go. Not sure if it works, but you can get a set of the armor when you start the game, i had sold mine though :( Went back to helgen to try and find some, but i couldnt, and i also tried the traders in solitude, with no luck. – user17386 Dec 30 '11 at 4:29
You could possibly try buying it back from whoever you sold it to, but I doubt they will still have it. – Jonny Dec 30 '11 at 5:18

Edited. UESP has conflicting information, attempted and failed. The option isn't available, but should be. Some programming error or something keeps it from working right. So, no not until it's patched or fixed either by Bethesda or modders. No peaceful solution exists, and there is no such armor. A book related to the quest can be gained using console commands, but it does nothing aside from take up inventory space.

share|improve this answer
Pics or it didn't happen – bwarner Feb 1 '12 at 14:41
Working on confirming it, will link to screenshots if it works. This is one of the things the 4.1 patch is supposed to fix, and I've got the beta patch installed. I started a new game recently, so I have to go through the entire quest line to confirm it. – Contrabardus Feb 1 '12 at 21:33
Well, UESP contradicts itself here, on the same page no less. However, it is correct that there is no peaceful way to do this as of yet. There is no such armor, only Imperial heavy armor. The 1.4 patch hasn't fixed the issue, and I noticed it was taken off the list of fixes slated for this patch. I suspect it will be addressed, as it was briefly amongst the list of things that was supposed to be addressed. Short answer, the only way to complete this peacefully is to wait for Bethesda to patch it, or mod the game later on with a fix for it from the ES Nexus. Neither option exists as of yet. – Contrabardus Feb 5 '12 at 2:06
Do you want to edit your answer to reflect what is in your comment? As it is, the answer still looks wrong. – bwarner Feb 5 '12 at 4:00

You can't obtain the Imperial Legoinaire Armor as it doesn't exist. But however, there is another way to release Thorald without bloodshed.

Release Without Bloodshed, Step 1

What you'll need to do is join the Imperial legion and you need to start the rescue quest. Talk to General Tullius in the Castle Dour in Solitude to release the prisoner at Northwatch Keep. He will give you the Imperial Orders you need to give to the Thalmor at the front gate. This will cause the Thalmor at Northwatch Keep to become unhostile.

Release Without Bloodshed, Step 2

Now, go to Northwatch Keep. Talk to the Thalmor at the front gate and persuade him to release Thorald Grey-Mane and give him the Imperial Orders. He'll lead you inside the keep and you need to talk to Thorald to tell him he'll be rescued. then he'll follow you all the way outside. Don't worry, as the Thalmor will still become unhostile for the rest of the gameplay.

Release Without Bloodshed, Step 3

Now you released Thorald without having to kill the Thalmor. Talk to Fraila to complete the "Missing in Action" quest.

You can't obtain the Legionaire Armor to relase him, but you do want to do what is above. That's how you do it. The Wiki says:

-If the Dragonborn speaks to the front guard of Northwatch Keep and tells him that they've come for Thorald, the guard will refuse to confirm whether they hold a prisoner by that name, and say that a prisoner can only be freed by order of the Imperial Legion. General Tullius in Solitude can be asked to release Thorald, but he will only say this would cause too many problems (This option is glitched and there is currently no way to use it on PS3 or Xbox, and needs mods on PC.). He will only allow Thorald to be pardoned after finishing the Imperial Legion questline.

But if you have the Unofficial Patch,

-"Missing in Action" can now be completed using the non-violent method Bethesda had partially implemented.

Then you can release Thorald without bloodshed and but no Legionnaire Armor!

share|improve this answer
What's the source of these peaceful solutions? Did you test them yourself? If so, what version of Skyrim are you using? – k0pernikus Oct 13 at 7:12
I tried this on P.C. I had Unofficial patch. – Jim Oct 15 at 1:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.