Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I fired up Steam to launch Skyrim. Now when I press play from the splash screen it just disappears and then shows the splash screen again.

How can I see what is going wrong? How can I fix it?

share|improve this question
1  
Have you verified the game integrity? (Steam right-click option) –  Raven Dreamer Dec 2 '11 at 2:59
    
possible duplicate of Skyrim launcher keeps prompting for elevation, but never launches –  Nick T Dec 2 '11 at 2:59
    
@Raven - That was it! Post as an answer and I will accept. –  Vaccano Dec 2 '11 at 3:21
    
@NickT Different problem, same resolution. –  Raven Dreamer Dec 2 '11 at 3:32
1  
@NickT - I was not getting elevation prompts and I tried running in admin mode too. –  Vaccano Dec 2 '11 at 3:52

1 Answer 1

up vote 4 down vote accepted

Have you tried verifying the game's integrity? It sounds like something might have gotten corrupted, and rather than crashing, the launcher is recovering (though not giving you an error message to let you know something's wrong).

enter image description here

enter image description here

enter image description here

share|improve this answer
    
Note: After doing this, my Up and Down look sensitivity was shot. (Took me pulling my mouse down a lot of times to move just a tiny bit.) I adjusted my fMouseHeadingYScale to 1.3200 and it seemed to work beter. (Note I had modified this previously.) –  Vaccano Dec 2 '11 at 3:46
    
@Vaccano There was another question about Skyrim updates messing with your configs. I'd follow the answer there to prevent this from happening again. –  brymck Dec 2 '11 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.