Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I followed the instruction here to run Terraria on my Fedora install, and when I went to install .NET 4, it said it was already installed. I deleted the registry node, as the instructions say, but it still says it's installed. I tried following the rest of the instructions anyway, but when I try to launch it, nothing happens. Does anyone have suggestions I could try?

share|improve this question
    
I found a .verb script in the appdb, so I'll try that sometime tonight. –  SaintWacko Dec 5 '11 at 22:53
    
Oops. I got so caught up in actually playing I forgot to boot back to Fedora and test the .verb. –  SaintWacko Dec 6 '11 at 16:54
    
did you check winehq‌​? –  Zommuter Jan 6 '12 at 6:47
    
Yes, that's where I found the link to the .verb that I keep planning to try. –  SaintWacko Jan 6 '12 at 16:12

4 Answers 4

up vote 4 down vote accepted

Still not working under Fedora? Hmm. Make sure you regedit .NET install key out of the right wineprefix. Using winetricks GUI, that means selecting the right radio button, if it isn't the default one. Also double check if it's the correct registry key you're editing out.

share|improve this answer
    
That could very well be it. I deleted the registry key, but I'll bet I deleted it out of the wrong bottle. I'll have to try that when I get home. –  SaintWacko Dec 12 '11 at 23:14

One problem I had with this (with nearly identical symptoms), was that I didn't keep close enough track of where all the stuff I was installing was going.

In particular, Winetricks installs (well did for me, anyway) Steam in its own wineprefix. I was installing my dependencies to the default one.

Once I fixed it (by adding

WINEPREFIX=<path-to-wineprefix>

to my commands), it all worked.

If it still doesn't work, make sure you have a version of Wine at least as new as 1.3.19.

share|improve this answer
    
I suspect that's my problem. I kinda stopped playing Terraria for a while, so I haven't gotten back to trying to install it yet. I've been playing Minecraft and Dwarf Fortress instead :D –  SaintWacko Jan 6 '12 at 16:11

There's a mono port of the engine called Linaria, have a look at that.

share|improve this answer
2  
Can you elaborate? A link or a brief explanation of why this would help would be really useful. –  fredley Sep 12 '13 at 13:12
    
This sounds very useful. I'm not currently using Linux, but if it works for someone else, let me know. –  SaintWacko Sep 12 '13 at 14:21

Try deleting the entire node that the one you deleted, it should fix it.

share|improve this answer
3  
Welcome to the site! Could you clarify your answer? I'm not sure what you mean by "that the on you deleted" –  Wipqozn Jan 31 '12 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.