Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am running Doom3 on Linux. Everything worked out fine, as described in this documentation but I ran into a fix when I changed my screen resolution.

Now the games starts in a bigger window, the bottom part of which is inaccessible as it extends beyond my laptop screen size. The mouse pointer moves only inside this window, so neither can use the Doom UI nor can I move this Doom window to make the UI visible.

Is there a config file somewhere where I can specify the screen resolution, or some command-line parameters with which to start Doom3 ?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

First, exit the game. Then open the base/DoomConfig.cfg file inside your Doom 3 installation directory and edit or add the following values, substituting your desired resolution and aspect ratio.

seta r_customHeight "1050"
seta r_customWidth "1680"
seta r_mode "-1"
seta r_aspectRatio "2"

The aspect ratio values are 0 for 4:3, 1 for 16:9 and 2 for 16:10.

You can also run these commands in-game if you have access to the developer's console (opened with the backtick/tilde key). If you go that route, you also need to run vid_restart after changing these settings.

share|improve this answer
    
+1, this works for all games based on the Tech 3 engine. :) –  badp Jul 31 '10 at 8:08
    
Thanks! That was helpful. –  rup Aug 1 '10 at 3:06
    
the aspect ratio doesn't change for me... I can set the resolution just fine, but the mars planet in the main menu is still very, very oval :( (1600x900) –  Mala Feb 28 '11 at 0:56
    
I take that back - it fixes in game, the menu just doesn't change. Thanks! –  Mala Feb 28 '11 at 1:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.