Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am trying to become Thane of Haafingar hold/ Solitude.

I cleared out Wolfskull cave, Elisif asked me to take her Husband's War Horn to a shrine of Talos. It shows up as a Misc Journal entry.

Where is this shrine?

I tried taking it to the shrine in Whiterun where the priest was always yelling. No luck, no options to leave the horn there.

I tried following this Guide, I kept and kept on searching. Nothing between north of ritual stone or east of Whiterun resembles what they are talking about. But it is a radiant quest so I think that information might be dated.

This guide says to go to the appropriate shrine.

Our very own guide has no such mention, meaning it should be an easy do.

I have been wandering looking for this shrine for almost 2 hours now real time.

Which shrine of Talos do I need to drop the horn? And more importantly where is it/ How to find it?

share|improve this question
    
Have you tried clicking the quest to activate it, then pressing M to have it show you the quest on the map? It should lead you right there. –  bwarner Dec 10 '11 at 20:02
3  
Make sure the quest is active in Miscellaneous, and make sure that Miscellaneous is active itself. Then you should see a map marker for it. For me, I was standing on top of a rock, supposedly directly at the marker. I was confused, annoyed, and decided to drop down from the rock and move on. I dropped down to discover that the rock was the top of a small cave. Inside the cave was the shrine. Too easy. –  Thaumajig Dec 10 '11 at 22:28
    
Miscellaneous is active, how to make a quest within miscellaneous active? –  ヴァイシャリ Dec 11 '11 at 0:20
    
You can activate-click them in the miscellaneous list, too. –  ordag Dec 11 '11 at 10:08
    
@ordag I am on PC. I open J my journal, navigate to Miscellaneous, if I press E key the Miscellaneous quests are activated. But can not activate the quests in my Miscellaneous tab. –  ヴァイシャリ Dec 11 '11 at 10:59
show 1 more comment

1 Answer

up vote 31 down vote accepted
+50

It's very hard to find, and the shrine doesn't have its own world marker, but it's there, east of Whiterun under a ledge:

Image of shrine

Shrine location


enter image description here

share|improve this answer
    
+1 for the great directions. I still do not see it. Followed the whole river, and paid special attention to your map. Can not find it still. –  ヴァイシャリ Dec 11 '11 at 2:22
1  
Trying it now. Wish I can upvote more. You do deserve it for all your effort. –  ヴァイシャリ Dec 11 '11 at 12:12
    
I found it so easy to find thanks to your instructions man ... cheers –  user16491 Dec 14 '11 at 23:50
    
It may not have a world marker, but it does have a quest indicator. –  Raven Dreamer Dec 15 '11 at 0:46
    
@ordag Finally found it when I had stopped looking. Based on your directions I knew where it was. I was doing a different quest and finally found it. –  ヴァイシャリ Dec 15 '11 at 10:16
add comment

protected by Community Feb 1 '12 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.