Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am running the game on medium settings, with textures set to high and AA, AF off. I have not seen any stutter or FPS drops outside or in cities, but certain dungeons are causing weird lag. Mostly when there is a "rain" effect in them, or the dust in tombs. I suppose those are shader effects. The only changes I have made to the ini file are turning off Vsync and Mouse acceleration.

I am playing the game on HP Probook 4530s, Pentium B940 2.0 GHz, Radeon 6490m 1 GB and 4 GB DDR3 RAM.

Anybody had the same issues?

EDIT:
So I have measured FPS using Fraps and it's really getting interesting. I measured it in Bthardamz and there is definitely some weird lag. But I'm getting about 35 fps, sometimes it goes down to about 25 for a second, but sometimes it goes up to 60. Depends on how much stuff is there to render. Yet the lags are happening independetly of the amount of frames. And since even 25 is high enough to be unnoticeable, I don't think it has to do with performance. Consequently, lowering shadows didn't help.

share|improve this question
    
So you lag with rain and dust. What about fire? –  Arkive Dec 15 '11 at 16:47
    
Do you also lag in the Ragged Flagon - Cistern? I do, and I think its the waterfall, although I seem to not have any issues with waterfalls out in the open world. –  JoeB Dec 15 '11 at 16:54

5 Answers 5

up vote 5 down vote accepted

Mostly when there is a "rain" effect in them, or the dust in tombs

I think you're talking about the "light rays coming through the roof" type of effect, and the fog that covers the floor in most dungeons and caves.

In certain areas it is very concentrated and causes a significant dip in framerate, as well as input lag.

On your system it may not be evident that the framerate and input lag are connected because the FPS hit isn't too bad. I played Skyrim over the weekend on a 2009 MacbookPro with a Nvidia 9400M! Was pretty stunned that the game would run at all. Had a program to monitor the GPU temp, fan speed, and also overclocked the GPU. Then I created a custom 1152x720 resolution with the Nvidia control panel. This let me play at an average 22-25 FPS outdoors which is pretty nuts all things considered! What was more amazing to me, is just how incredible the load times are, as they were just as fast on that system, with hgih detail textures, that they are on my Core i5/4850 iMac! So I don't think Elder Scroll's engine is as bad as people make it to be... but I digress.

Back to the topic: in caves and dungeons, it would sometimes dip to 5 FPS!

I'm pretty sure it is not related to GPU shadows. This is one of the first tweaks I tried on the Nvidia 9400M, and it made very little difference. You can sort of disable shadows by changing the shadow distance settings in the SkyrimPrefs file:

fShadowDistance=0.0000
fInteriorShadowDistance=0.0000
fShadowLODStartFade=0.0000

This effectively removes shadows. I played several hours like this, only to find out later that the GPU shadows had a very little impact on performance. On that system I gained only 1-2 FPS. However the change in graphics quality was huge, because editing the settings as above, turns off a lot of lighting that creats dramatic ambiance. Perhaps there is a better way to turn off shadows, but effectively the settings above turned off more than shadows.

Then, on the SkyrimNexus website you can find the mod Fog Mesh Remover which, as is explained on the description page, does not actually improve performance. Still I tried it thinking that perhaps the GPU would skip the polygon entirely if it is all 0 alpha but it doesn't.

Last but not least there was another setting I saw that was suggested. You can reduce the number of particles like so:

iMaxDesired=50

Reportedly, the particles are used to make the "ambiant dust". Having tried this, I found no change in performance. I suspect that the person confused the "dust in the light" texture effect for particles. They are a texture however, which slowly pans to give the impression of dust floating in the air.

Short answer: the fog/light ray/ambiant dust effect appear to be mesh-based, and appears to be fixed in the scenery itself. So there is no setting to turn it off entirely that I know of. Perhaps this will be possible once the Creation Kit comes out starting in January.

share|improve this answer

I turned down shadow quality and my certain dungeon lag went away.

In particular, there's a small bandit mine with a very narrow unpassable hole from the entrance to a lower level. That dungeon knocked me down to 1 fps with high quality shadows and plenty of fps with low quality shadows.

share|improve this answer
5  
RhetoricalToSelf: Is that where small bandits are mined? –  David B Dec 15 '11 at 14:50

Try these mods (I'd try them in the order I put them):

  • Unofficial Skyrim Patch - a comprehensive bugfixing mod; also contains a "savegame debloatifier" feature that may help improve performance

  • Skyrim Performance PLUS - installing it will give little (unnoticeable) graphics degradation, while certain CPU-intensive effects (falling rain, snow, leaves, etc.) are underway

  • Interior and Dungeon Fog Remover
    Description:

    Replaces most default "fog" meshes with blank ones.

    Several people have commented saying they are getting better performance in specific areas, so if you notice unusual performance drops in the presence of fog, this might help you.

  • Colorful Lights - No Shadows - More FPS
    Description:

    If your computer spec lurks somewhere near or below the edge of the recommended minimum system requirements you have probably noticed that the option to disable shadows is not offered in the launcher, and consequently may have noticed that the low quality shadow settings look like garbage. If you scratched a little deeper you probably tried disabling shadows by changing the commonly recommended ini values and were disappointed to find everything had turned dark and colorless. The vanilla shadow options amount to menu choices between a garbled blocky flickering striped mess and a beautiful slide show, or editing the ini to induce a global dungeon vibe. This mod offers a alternative that I think strikes a nice balance between eye candy and system performance by removing most of the system-hog shadows. Everything will still be shaded to create the static, nice-looking shadows and colorful lights that utilize relatively little system resources. The shadows that are removed by this are the dynamically-rendered flickering shadows, commonly found near flames.

  • injectSMAA - like FXAA, but looks and performs better (disable FXAA if using this)

  • Bethesda HD Textures Redux

    This is a cut down version of Bethesda HD texture pack for Skyrim. It aims at improving Skyrim visuals while, at the same time, allowing PC users with old systems to benefit from higher resolution textures.

share|improve this answer

This problem can be solved with a FPS limiter. For Nvidia there's the Nvidia Inspector tool (very small app) and for AMD try the MSI afterburner app, or you can try this FPS limiter mod http://skyrim.nexusmods.com/mods/34 (which didn't work for me but might for you)

For your setup limit the fps to 30 and you'll get rid of most of those jump in frames. As you noticed they are caused by the jumps in FPS. You may need to enable again vsync as there will be a lot of screen tearing, which means mouselag in menus, but trust me on the long run it's a lot more bearable than those frame skip in dungeons.

Have fun.

share|improve this answer

I had the same problem, only stutters in certain parts of some dungeons. I read on another forum that the problem vanished when in windowed mode. So I tried the simple borderless window mod. that gives you fullscreen window mode.

After I did this, every place is buttery smooth for me. I hope this helps others that have the same problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.