Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm running Ubuntu 11.04, and every time I try to run VVVVVV, it freezes. It won't let me do anything, and before long the window darkens and it tells me that the program is unresponsive and asks me if I want to force quit it.

When I launch it from my app launcher, it freezes at the "Press Action to Continue" screen. When I launch it from Steam, it freezes during the initial cutscene.

I've tried Googling, but Google appears to ignore the search term "VVVVVV".

I tried running it from the terminal, and it gave little output*, none of which mentioned an error.

What's my problem and how can I fix it?

*The exact output is:

Levels will be saved to: /home/john/.vvvvvv/


            VVVVVV


          8888888888888888  
        88888888888888888888
        888888    8888    88
        888888    8888    88
        88888888888888888888
        88888888888888888888
        888888            88
        88888888        8888
          8888888888888888  
              88888888      
          8888888888888888  
        88888888888888888888
        88888888888888888888
        88888888888888888888
        8888  88888888  8888
        8888  88888888  8888
            888888888888    
            8888    8888    
          888888    888888  
          888888    888888  
          888888    888888  


the complete reloaded file size:57761373
data/music/0levelcomplete.oggunpacked
data/music/1pushingonwards.oggunpacked
data/music/2positiveforce.oggunpacked
data/music/3potentialforanything.oggunpacked
data/music/4passionforexploring.oggunpacked
data/music/5intermission.oggunpacked
data/music/6presentingvvvvvv.oggunpacked
data/music/7gamecomplete.oggunpacked
data/music/8predestinedfate.oggunpacked
data/music/9positiveforcereversed.oggunpacked
data/music/10popularpotpourri.oggunpacked
data/music/11pipedream.oggunpacked
data/music/12pressurecooker.oggunpacked
data/music/13pacedenergy.oggunpacked
data/music/14piercingthesky.oggunpacked
The save directory exists at: /home/john/.vvvvvv/
Quick Save Not Found
Teleporter Save Not Found
JoyStick name: Microsoft Microsoft® Digital Media Keyboard 3000

Obviously I don't want to post all of dmesg here, but these lines looked important:

[   17.663941] [fglrx:__mc_heap_map_virtual_space] *ERROR* Failed to map the virtual space
[   17.663945] [fglrx:mc_heap_map_virtual_space] *ERROR* Can not get virtual address

It should be noted that I am using the fglrx driver.

share|improve this question
add comment

2 Answers 2

Those messages from dmesg are the most important factors here.

It appears your fglrx drivers are either outdated or broken/misconfigured. If there are fglrx updates, I'd get them (note that the fglrx version in the repositories isn't nearly as up-to-date as the one from ATi's website - but that one requires a little more work to install than the one from the repos).

Alternatively, if you can't or don't want to update fglrx, try using the open-source 'radeon' driver instead of fglrx - that driver might not have as many features as fglrx, but it's far more stable and better maintained.

Personally, I tend to avoid ATi cards on linux systems since I've had horrible experiences with them in the past - that, and in my experience nVidia-based cards give better performance anyway (even on Windows). If you have a lot of problems like this, I'd suggest switching to an nVidia chipset (if possible).

share|improve this answer
add comment

Do you run the native VVVVVV version when you use the app launcher or the Windows/STEAM version?

Please run it from a terminal and name the command you entered and the little output.

Check dmesg, too.

If you run the Windows version, there is a freeze problem known when using fullscreen mode.

More information online at winehq.org (VVVVVV).

share|improve this answer
    
I run the native version from the launcher, and the Windows version from Steam. I don't have access to that computer for another week, but I will post that output as soon as I can. –  John the Green Dec 26 '11 at 16:15
    
I have updated my question with the information you asked for. I run the native version from the launcher, and the Windows/Steam version from Steam. I have tried both (exclusively in windowed mode). –  John the Green Jan 16 '12 at 4:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.