Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Every time I start The Old Republic launcher/updater, it throws up the UAC prompt. Is this normal? If it isn't (or is I suppose), how do I prevent it without disabling UAC?

share|improve this question
    
I wish I knew. The C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic folder already has Everyone assigned the Full control meta-permission in the file system, likely changed to that by the installer. –  user2974 Dec 20 '11 at 1:39
    
What do you mean by UAC? –  Fredy31 Dec 20 '11 at 1:43
    
@Fredy31, User Account Control, the dialog that shows on Vista and above when doing privileged actions like installing an application. –  svick Dec 20 '11 at 1:45
    
Oh, Windows7 FTW. But I'm afraid I cant help you on that question. –  Fredy31 Dec 20 '11 at 1:46
3  
@AnnaLear: Setting "Run as administrator" does not disable the prompt. That option only requests admin rights if the app doesn't already asked for them, which in the SWTOR doesn't matter since it is already configured to ask for them. So this option won't solve the problem. –  Mufasa Dec 20 '11 at 2:00

5 Answers 5

up vote 12 down vote accepted
+50

It's a bit of a hassle to set up.

Before I start, here's an installer for the end result, if you are willing to trust me. You'll only need to rename the VC redist as described at the end of this answer.

This installer applies Microsoft compatibility shims to remove the "Administrator required" flag from the launcher.


How to create your own Shim database for SWTOR

You'll need to use Microsoft's Application Compatibility Toolkit to apply shims to the launcher.

  1. First, download and install both the Compatibility Toolkit and the Application verifier.
  2. Run the Compatibility Toolkit's Standard User Analyzer Wizard. It is located in Start Menu > Microsoft Application Compatibility Toolkit > Developer and Tester Tools
  3. Enter the location (or browse for) the launcher. It should be in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic
  4. Click Launch
  5. Very Important: You should see 2 LUA Prompts: the first for the Standard User Analyser and the Second for the SWTOR Launcher. Accept the first but decline the second.
  6. The Analyser will ask whether the application ran without problems. The launcher should not have launched (If it did, you may have accepted the LUA prompt I said to decline earlier). Click No
  7. The Analyser will suggest some mitigations. You should only need ForceAdminAccess*, but if it doesn't work, you can check them all; it will only loosen some security in a few extremely specific folders/registry keys. That should not cause any problem in an environment that allows you to play SWTOR.
  8. Click "Launch" to test the settings.
  9. The launcher should have launched properly without any prompts. If it didn't, click no and select somemore mitigations in step 7.
  10. Once the launcher works properly, Click Yes then Export to create an msi file containing your fixes.
  11. Run the generated MSI to install the shims permanently.

There is one last step to take care of every last prompt. In the extras folder of your SWTOR installation (so C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\extras), there should be a file named vc2008redist_x86.exe. Rename it to vc2008redist_x86.exe.unused


* Despite the name, ForceAdminAccess does not automatically grant admin access as if you accepted the LUA prompt. It simply lies to the launcher when it asks whether you are an admin.

share|improve this answer
    
Copied over from my own answer to this question: gaming.stackexchange.com/questions/44322/… –  3Doubloons Jan 3 '12 at 14:21
    
Out of curiosity, what rights are you granting the launcher? –  Nick T Jan 3 '12 at 16:11
1  
The included MSI applies the ForceAdminAccess shim to the launcher and rundll32 which should only tell the application (launcher in this case) that it is running as an administrator even though it isn't. This is the only shim applied. More information on ForceAdminAccess: technet.microsoft.com/en-us/library/cc766024(WS.10).aspx –  3Doubloons Jan 3 '12 at 16:34
    
This was great, thank you. FYI, I actually had to scale back the mitigations and select only ForceAdminAccess on the launcher and rundll32. I'm on Windows 7. –  John Moeller Jun 6 '12 at 23:58

It's possible the update launcher itself specifies that it needs admin privileges in its manifest.

Download Microsoft's LUA buglight tool here to see what is tripping the UAC prompt.

http://blogs.msdn.com/b/aaron_margosis/archive/2011/03/23/lua-buglight-2-1-1-with-support-for-win7-2008r2-sp1.aspx

To use this tool, you'll need to run it with UAC on and admin approval mode enabled.

The otherway is to use Microsoft's Application compatability Kit. I'm not going to step through how to use that thing, but if it is the manifest this may fix it.

share|improve this answer

I successfully run the program using Compatibility Mode for Windows 2000.

Find launcher.exe and go to the program Properties (Right-click > Properties) > Compatibility tab. There, check the Run this program in compatibility mode for: box, and select Windows 2000 in the Drop-down.

My specific information: I'm running Windows 7 with or without UAC (on a non-administrator account, of course), and installed to a location outside of my Program Files directory.

Edit: I received negative votes because people thought this solution requires a user to disable UAC. This solution does not require you to disable UAC. I have verified that this works with UAC as well (i.e. does not show the UAC prompt).

share|improve this answer
    
-1 because this didn't work for you? –  palswim Jul 13 '12 at 16:55
    
The question says "how do I prevent it without disabling UAC?", and you have UAC disabled. –  Matthew Read Jul 13 '12 at 16:59
    
Ah, but under normal circumstances without UAC, you can't even run the launcher (see the other question). Since my solution allowed me to run the launcher as non-admin without UAC, I propose that it will work with UAC, without invoking the UAC prompt. –  palswim Jul 13 '12 at 17:05
    
I'd recommend testing this with UAC enabled, and then updating your answer. –  Frank Jul 13 '12 at 17:13
    
I have tested this with and without UAC. It runs under a non-administrative account without showing the UAC prompt. –  palswim Jul 13 '12 at 17:55

I managed to do this on windows 8.1 today by following the guidance mentioned on the swtor forums at the following link

How to prevent SWToR from demanding Administrator rights.

But instead of selecting windows xp sp 2 I selected windows 2000 sp 2, because the game wouldn't start properly otherwise

I will now describe what I did. You will need administrator rights to set this all up.

  1. Download and install the "Microsoft Application Compatibility Toolkit 5.6"
    http://www.microsoft.com/en-us/download/details.aspx?id=7352

  2. Launch the 32 bit version of the Compatibility Administrator, the default location on a 64 bit install of windows 8.1
    C:\Program Files (x86)\Microsoft Application Compatibility Toolkit

  3. Under custom databases right click on the default custom database, which in my case was called "New Database(1) [Untitled_1]" , and select "Create New""Application Fix..."

  4. A dialog box will appear where you can enter some information about the application, the name of the program, the name of the vendor and the program file location, the program that you need to care about is the swtor launcher, which is called launcher.exe and will be in the folder where you installed swtor, I installed it in "C:\Star Wars-The Old Republic", so the full path to the launcher is "C:\Star Wars-The Old Republic\lancher.exe" this is what I put into the program file location box. You will need to identify the location of this file (probably program files) and use that as the program file location.

    Press next.

  5. The next dialog allows you to specify the compatibility mode that you want. At first I had followed the advice on the SWTOR forums, which specified that "Windows XP Sp2" should be selected, but found that it didn't work for me, so after some experimentation I found that selecting "Windows 2000 (Service Pack 2)" allowed me to launch the game, login and play. Also be sure to select the RunAsInvoker option in the additional compatibility modes list.

    Press next

  6. The next dialog displays a detailed list of the fixes that will be applied. There is no need to change anything here.

    Press next.

  7. The next dialog displays a summary. No need to change anything here.

    Press finish

  8. Now you must save the database. Give it any name you like.

    Save it in any location you like, I saved it in my SWTOR folder.

  9. Right click on the newly saved database and select install.

  10. Give full control to users that will play the game, I just gave full control to everyone.

  11. Launch the game, by invoking the launcher.exe or make a short cut to it and use that to launch it. You can do this as non admin or as admin, both work and there is no uac dialog.

share|improve this answer

The shortest and quickest way to do this is unfortunately to disable your UAC settings:

Running as admin or running in a compatibility mode does not make any difference.

There are many and varied opinions on UAC, some people insist on leaving it on, whilst some self proclaimed professionals "never use it". All of them swear by a good firewall and anti-virus. I do not accept any responsibility for anything happening to your PC if you disable UAC. For your information, some of the more interesting talks on SWTOR and UAC can be found through these links:

The way that other MMOs have fixed this is by writing to public files on the computer as opposed to system files, SWTOR does not do this (yet), but hopefully they will see the noise on the forums and implement it in a patch soon.

There does appear to be an other workaround that I am currently investigating, and I shall amend this answer once I have confirmed that it works.

I hope this helps.

share|improve this answer
    
Disabling UAC is a horrible idea and there are others solutions –  Ramhound Jul 27 '12 at 1:07
    
@Ramhound: would you mind sharing the rationale for why it's a horrible idea to disable UAC? –  0xC0000022L Jul 2 at 22:30
    
Security for one. There is no difference between UAC prompt and a request for Sudo in Linux both inform there is a privileged action about to happen. The accepted answer is the best secure solution –  Ramhound Jul 2 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.