Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've been playing Skyrim and have came across what I think is a bug.

During the quest "A Night to Remember" I have found two items missing. When I went to rescue Gleda the Goat from the giant neither Gleda nor the giant was there. There was just an arrow pointing at the ground, so I just returned to the farmer and gave him money.

When I went to collect the wedding ring from a cabin in some woods I killed the witch person outside but when I searched the cabin there was no ring. I also searched around the cabin, the witch and the chest next to the door and I don't want to have to give away 2000 gold. I've tried reloading, waiting, sleeping and can't think of anything else to do.

Does anyone know how to get the ring?

share|improve this question
    
Not directly relevant to your question but this quest seems to be really buggy - I never did half of it. After I got drunk I just intimidated Adrienne, who told me where to find Sam. I went to the dungeon, cleared it and then the quest finished. She had been talking about the wedding but I never did anything about it :/ –  Alex Dec 22 '11 at 22:45

2 Answers 2

up vote 3 down vote accepted

Very odd - I found the wedding ring on the witch myself, so it does sound like a glitch. Unfortunately as an Xbox user you can't abuse the console into solving the problem.

If I remember correctly if your speech is high enough, you should be able to persuade/intimidate Ysolda into telling you the next location for the quest. This looks to be your only option if you don't want to pay.

share|improve this answer
    
i tried pursuading her but it didn't work so i just payed but thanks for the advice:) –  the guy Dec 22 '11 at 20:09

I found the ring on the witch. The item name is "Wedding Ring".

share|improve this answer
1  
thanks for help:) –  the guy Dec 22 '11 at 20:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.