Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm trying to install OptiFine on minecraft and I'm taking the following steps:

  1. Open minecraft with archive manager
  2. Delete the Meta-Inf folder
  3. Open OptiFine with archive manager
  4. Copy contents of OptiFine to minecraft archive
  5. Close both archives
  6. Open minecraft with java -jar minecraft.jar
  7. At this point I get `Invalid or corrupt jarfile minecraft(1) (copy).jar!

Even just deleting the meta-inf folder gives me this error. I'm on linux mint 12. Any help is greatly appreciated!

share|improve this question
1  
The problem may be outside the minecraft.jar. Try this: backup your .minecraft folder; delete it; load fresh minecraft; do what you wanted to do. –  Olegs Jeremejevs Dec 24 '11 at 13:41
    
What archive manager are you using? –  Kenan Dec 24 '11 at 23:30

2 Answers 2

up vote 4 down vote accepted

You must rename it to: minecraft.jar.

share|improve this answer

You need to make sure your jar is named minecraft.jar

I would suggest deleting your bin folder and letting Minecraft download a fresh copy before trying this again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.