Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Stupidly long story short...

I have access to Windows 7 computer that I can only log into with a "Guest" account. The Guest account does not have Administrator access.

Star Wars: The Old Republic is already installed, and in fact there is a shortcut on the desktop; however, attempting to run it prompts me for an Administrator password. I do know someone who is an Administrator, but I don't want to bother her every time I want to run the game.

Can I play Star Wars: The Old Republic on this machine, and if so how? I am willing to have the Administrator set something up (a shortcut or something), just so long as I can run it without her help.

share|improve this question
2  
Related, if not duplicate (as this is probably why it's asking): gaming.stackexchange.com/questions/42747/… –  Nick T Dec 28 '11 at 6:23
    
@Nick Not really the same question. Looks like the UAC prompt happens, even on Admin accounts, if you have UAC on. That's not the issue, here, though they are related - looks like the solution might end up being the same. What a pain! –  Mag Roader Dec 28 '11 at 16:01
    
@MagRoader: They are exactly the same reasons. Remember, even on Admin accounts, programs are launched with User rights. A program that pops a UAC on an Admin account will also pop a UAC on an User account and vice versa. –  surfasb Dec 28 '11 at 20:28
    
I posted an answer to How do I stop the launcher bringing up the UAC prompt every time? that I have tested on windows 8.1 –  Alex Feb 1 at 19:34
add comment

3 Answers

Technically, yes but it's a bit of a hassle to set up.

You'll need to use Microsoft's Application Compatibility Toolkit to apply shims to the launcher.

  1. First, download and install both the Compatibility Toolkit and the Application verifier.
  2. Run the Compatibility Toolkit's Standard User Analyzer Wizard . It is located in Start Menu > Microsoft Application Compatibility Toolkit > Developer and Tester Tools
  3. Enter the location (or browse for) the launcher. It should be in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic
  4. Click Launch
  5. Very Important: You should see 2 LUA Prompts: the first for the Standard User Analyser and the Second for the SWTOR Launcher. Accept the first but decline the second.
  6. The Analyser will ask whether the application ran without problems. The launcher should not have launched (If it did, you may have accepted the LUA prompt I said to decline earlier). Click No
  7. The Analyser will suggest some mitigations. You should only need to check Force Administrator Access (*), but if you want to be sure or if it doesn't work the first time, you can check them all; it will only loosen some security in a few extremely specific folders/registry keys. That should not cause any problem in an environment that allows you to play SWTOR.
  8. Click "Launch" to test the settings.
  9. The launcher should have launched properly without any prompts. If it didn't, click no and select somemore mitigations in step 7.
  10. Once the launcher works properly, Click Yes then Export to create an msi file containing your fixes.
  11. Run the generated MSI to install the shims permanently.

There is one last step to take care of every last prompt. In the extras folder of your SWTOR installation (so C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\extras), there should be a file named vc2008redist_x86.exe. Rename it to vc2008redist_x86.exe.unused

(*) Despite the name, this shim does not give Administrator access to the launcher without your knowledge; it lies to the launcher telling it you are an Administrator when in fact you are not

share|improve this answer
2  
If anyone want to try to skip to step 11, here's my msi. I'm not making any promises to whether or not it'll work (For starters, I installed SWTOR on my D drive), but if it can save someone some time, then great. –  3Doubloons Dec 28 '11 at 7:03
    
This is a more detailed version of my answer. Excellent work. gaming.stackexchange.com/questions/42747/… –  surfasb Dec 28 '11 at 20:26
    
Thank you for this detailed guide. At step 7 I unchecked everything except "Force Administrator access" and it worked for me. But i'm wondering about this vc2008redist_x86.exe. Maybe someone can tell me why it does even exists if it isn't needed. –  raznagul Jan 2 '12 at 17:38
1  
It is technically needed, but only once. It's the installer for the Visual Vtudio redistributable dlls. Ideally, it'd only need to be installed once, but for some reason Bioware runs it on every launch. –  3Doubloons Jan 2 '12 at 19:21
    
For me, the default settings didn't work. But using just "Force Administrator access" did work. –  svick Jan 4 '12 at 22:37
show 3 more comments

I have successfully gotten the loader to work by first trying out the above method of changing the compatibility mode to that of Windows 2000 but it failed. So I then did the following:

From the Administrator account I right clicked the Star Wars KOTR icon and then I choose the option for Troubleshoot Compatibility. It will open up a small window, simply run the option for troubleshooting it in Windows XP service pack 2, then in the following window click on the start program button to test the loader and it should open the SW login window and you should be good, close out the login window and then click next and then click on the first option to save the settings and your all set!

Hope this helps anyone out that may be having the login issue with SW KOTR UAC error with Windows 7.

share|improve this answer
add comment

I successfully run the program using Compatibility Mode for Windows 2000.

Find launcher.exe and go to the program Properties (Right-click > Properties) > Compatibility tab. There, check the Run this program in compatibility mode for: box, and select Windows 2000 in the Drop-down.

My specific information: I'm running Windows 7 without UAC (on a non-administrator account, of course), and installed to a location outside of my Program Files directory.

I have also verified that this does not show the UAC prompt when using UAC.

share|improve this answer
    
This still needs to be tested properly. –  Frank Jul 13 '12 at 17:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.