Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am currently running OS X 10.7.2 with an updated version of Steam installed. I recently downloaded the Team Fortress 2 Beta to this Mac and then removed it via Steam's "Delete Local Game Content." This has left the "Team Fortress 2 Beta" icon stuck on the Launchpad, and I cannot remove it.

All of the typical methods for removing an icon have not worked (i.e., dragging to trash, Control+Option+Command+Left-Click, holding down left-click over the icon until icons start shaking, et cetera). I have uninstalled Steam and removed all game content and that has not deleted the icon.

I have also deleted the "Application Support" folder to try and force the Launchpad to reset itself; it did reset, but the icon stayed there. There is also not an icon in the Application folder for the game, or Steam (now that I've removed it).

Does anyone know how to correct this issue?

share|improve this question

2 Answers 2

up vote 10 down vote accepted

Steam creates “shortcut” applications in the Applications folder in your home folder, not the system-wide one. Unfortunately, it does not delete them when you delete a game, but you can delete them yourself; the path is /Users/[your account’s short name]/Applications, as shown in this screenshot.
enter image description here
Should you wish to recreate one of these, right-click on the game in Steam and choose “Create Desktop Shortcut”, then move the result from your desktop to your Applications folder. (This can be useful to restore a missing icon, though it only works sometimes for that.)

share|improve this answer
    
On a side note, the "only works sometimes for that" for desktop icons is the same situation as on Windows. I've had it lose the icon for HL2 of all things on Windows before, and that didn't fix it. :/ –  user2974 Dec 30 '11 at 7:35
    
Worked perfectly for me. Thanks! –  Chance Dec 30 '11 at 18:06

You have to go to Finder > Macintosh HD (or whatever hard drive you have) > Users > your username > applications and it should be there. For some reason this application folder is different then the standard and thats where mine was put. This worked for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.