Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I set the render distance to Far in mine craft (latest version as of December 30 2011) it says that I need to install 64bit java.

Interesting Information:

  • I am running Lion (Mac OS 10.7, latest version), 64-bit
  • I have 64-bit Java installed as well as 32-bit (proved in the screenshot below)
  • I ran a software update (to make sure I had the latest java version)
  • I also ran a "force update" in Minecraft
  • Restarted my machine several times
  • After Googling I checked to see if 64-bit Java was at the top of the list, it was (in screenshot)

This is the error message that I am getting:

64-bit error

Although I can still use the "Far" render distance, it is a tad choppy.

When I open Java Preferences (located in /Applications/Utilities) this is what I see:

enter image description here

share|improve this question
Have you tried disabling the 32-bit one? – Kurley Dec 30 '11 at 22:36
I haven't; I'll give that a try right now. – alexy13 Dec 30 '11 at 22:37
When I disable the 32bit one, it also disables the 64bit one (leaving both checkboxes unchecked) and vice versa. So it's impossible to disable one without disabling the other. – alexy13 Dec 30 '11 at 22:38
Hmm, can you give me the results of the Terminal command: file " OS/JavaApplicationStub"? I want to see if the stub that starts Java is 32 or 64-bit. – CyberSkull Dec 31 '11 at 4:44 OS/JavaApplicationStub: cannot open OS/JavaApplicationStub' (No such file or directory)` – alexy13 Dec 31 '11 at 13:59
up vote 13 down vote accepted

Minecraft on Mac OS X with 64-bit Java

So you're a slave to warning messages and you want Minecraft to use 64-bit Java. Here's how to do it on the command line. These instructions were crafted on MacOS Lion, which should prefer 64-bit Java when possible (Applications/Utilities/Java Preferences). These instructions assume the default location, in the main /Applications folder. I had a few tabs open, while I was sussing this out, including an excellent forum post, a post on JavaApplicationStub bits, and the official reference for CF keys.

Here we go.

Swap out Minecraft's JavaApplicationStub for the current OS' version:

gzip /Applications/  # save a backup
cp /System/Library/Frameworks/JavaVM.framework/Versions/Current/Resources/MacOS/JavaApplicationStub /Applications/

Then, add 64-bit architecture to Minecraft's possibilities:

/usr/libexec/PlistBuddy -c "Add :Java:JVMArchs:0 string 'x86_64'" /Applications/

Launch. That should do it. Watch out for creepers. Have a nice day.

If everything goes wrong, here's how to roll back from here to your original configuration:

rm /Applications/
gunzip /Applications/
/usr/libexec/PlistBuddy -c "Delete :Java:JVMArchs:0" /Applications/

I did not write this! Source

share|improve this answer
It worked! There is a definite speed boost. If I install a new version of Minecraft, will I have to redo these instructions? – alexy13 Dec 31 '11 at 14:04
Would I be allowed to use this code in a non-commercial program, made by myself? I would, of course, link back to this article and give you credit. – alexy13 Dec 31 '11 at 16:10
@Alexy13 All that code does is copy the up-to-date Java launcher into your application bundle and sets a flag in the application's preferences to use 64-bit Java. So yes you can use it to modify any Java application bundle to run in 64-bit. – CyberSkull Jan 1 '12 at 3:38
@Alexy13 I have not tested it myself so I don't know if you have to repeat the process when you update. I would think not. From my understanding you can use this "code" as much as you like. Though it's not my right to give this permission since I didn't write this. To be very sure you could ask the source article. – Anders Jan 1 '12 at 23:22
That didn't help. Still works in 32-bit mode. – DataGreed Feb 12 '12 at 23:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.