Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I love Khem. I really do. He gets his face bashed in on a regular basis so I don't have to.

But for all his "Yes, master", and "Watch your back, little Sith", I can't help but notice that he follows me everywhere at a distressingly short distance.

Normally, this wouldn't be an issue, but it makes trying to click on quest givers and archaeology nodes something of an unnecessary roulette. Do I get to click on the rubat crystal, or-- nope. "I HUNGER".

Of course you do, big guy. Of course you do...

Is there any way I can get my companion to follow me at a slightly longer distance, or otherwise resolve my companion's tendency to make it hard to click on things?

share|improve this question
    
Heh. I have the opposite problem with Vector, one of the Agent companions. He follows so far behind that the mob is often dead before he gets to hit it. –  LessPop_MoreFizz Jan 4 '12 at 1:49
    
@LessPop_MoreFixx: One thing I have found is to not click the companion Attack (Ctrl+1) until you are close enough to attack and they have caught up with you too. As soon as you give that order you are marked instantly in combat and your Sprint is disabled. That makes the companions take even longer to attack. –  Mufasa Jan 4 '12 at 4:04
    
Interrobang‽ Really‽ –  svick Jan 4 '12 at 9:25
1  
@svick Yes, really. –  John the Green Jan 4 '12 at 23:40
add comment

2 Answers

up vote 3 down vote accepted

By habit, I have positioned my clickies on the right of my character, on the presumption that the companion would take a position on the left. This is the behavior of the pets in World of Warcraft.

A little experimentation shows that pets don't behave this way in StarWars TOR. When you change your position, companions path to the closest point on a half circle behind you.

o  x  o
 *   *
  *z*

If they're coming from behind you, they are likely to stand right behind you(z) and obstruct your clicking.

If they're coming from in front of you, they'll choose one of the side positions(o), which might leave your clicking clear if the clicky is on the other side.

Just face your companion, and step back one tap.


If repositioning the companion this way doesn't work for you, another idea is to keybind the camera controls. ZoomIn, click, ZoomOut. I recommend F and V.

I do not recommend fighting in first-person cam (many effects do not appear, such as your own gunfire).

share|improve this answer
1  
you can also increase the max camera zoom in the settings to give a little more room to work. –  user4139 Jan 4 '12 at 8:58
add comment

I've found that increasing the max camera zoom (Located in the Preferences under Controls) to around 40% helps a lot with this. Being able to zoom out makes it much easier to click on what you mean to click on, and generally makes the game feel much less claustrophobic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.