Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I want my companion(Mako) to focus on only healing me but she keeps attacking people. How can I get her to only heal me and not attack? If she focused on healing I would be a lot better off. Does anyone know what to set to do this. I also keep turning off her attacking abilities and they keep turning back on. How can I prevent that?

EDIT:

They fixed this issue in the new 1.1.0 release!!!!! I listed the bug fixes below.

Bug Fixes

  • Companions will now sell trash items when requested, regardless of group size.

  • Companion healing abilities no longer apply a permanent green effect on the character.

  • Fixed an issue that caused Companion Characters to sometimes have the incorrect appearance in cinematics.

  • Companion abilities that have been disabled by the player no longer toggle back on when the companion is re-summoned.

  • Corrected an issue that caused the indicator that a companion wants
    to talk to you to disappear.

  • Companions no longer need to be re-summoned after selling trash items if the player mounts a vehicle after dispatching them.

  • Traveling from a Contested Area to a Contested Region now causes
    companions to be unsummoned correctly.

share|improve this question
1  
I'm going to take a wild guess that this falls under the broad category of 'Things that Are Broken In The Old Republics UI.' Related: My tank companion refuses to stay in tank stance, and the Cover Bar is reenabled seemingly at random no matter how many times I turn it off. Best you can do is probably watching like a hawk to make sure that those offensive skills are turned off and stay off. –  LessPop_MoreFizz Jan 4 '12 at 4:44
    
It's driving me crazy, but I just got her to heal me long enough to pass the quest I was on so I am happy for a few minutes. –  jer.salamon Jan 4 '12 at 4:47

1 Answer 1

up vote 7 down vote accepted

In Theory You should be able to do this by turning off auto-cast on all of your companions offensive abilities. You can do this by expanding their action bar (click the + on the right hand side of the 4 button action bar in their unit frame, at the bottom left of your screen.) See that green square in the top right corner of each spell? That's auto-cast. Right clicking on the spell will turn that off, and the square will become empty (black). Once auto-cast is off for a spell, your companion should never use it unless you specifically command them to (by actively clicking on that spell from their bar).

The reason this answer starts with in theory however, is because in practice, your companion will sometimes have all of their healing abilities on cooldown (or you will be topped off), at which point they might perform their basic attack.

share|improve this answer
    
That is the problem, the auto-cast keeps turning back on. I will need healing and the companion keeps attacking. In battle turning off auto-cast can be thousands of damage. –  jer.salamon Jan 4 '12 at 4:57
    
Khem Val turns his Consume Essence ability back on every time you summon him. I was rather hoping they'd push an update today to fix things like that. –  user2974 Jan 4 '12 at 5:16
    
@Powerlord Patch tomorrow, but autocast bugs doesn't seem to be in the notes. –  LessPop_MoreFizz Jan 4 '12 at 5:17
    
In my experience its not for totally arbitrary and unknowable reasons. It seems to be (from memory) every time you die, every time you use a lift or fast travel. Every time a loading screen appears (game start being the most obvious). Every time there is a cutscene (unconfirmed personally but a friend suggested it did). All in all a pain in the ass and just far too frequent to be practically worth the bother. :( –  Chris Jan 6 '12 at 16:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.