Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Has anybody been able to get either the rcon or gamespy4 services working on a minecraft server?

Following information on the wiki we've tried:


But this doesn't seem to enable either service... The ports are simply closed:

Interesting ports on localhost (
25564/tcp closed unknown
25565/tcp open   unknown
25566/tcp closed unknown
25567/tcp closed unknown
25568/tcp closed unknown

Any suggestions?

share|improve this question
Can you please explain how you got to see the log? – AlikElzin-kilaka Mar 19 '13 at 11:29
You mean the list of ports in the answer above? I used nmap to get that – TimothyP Mar 19 '13 at 16:12

Tzarium is not correct reguarding the nmap and networking issues. Nmap is 100% accurate; though you might need to use it properly and read its output carefully.

25567/tcp closed means that TCP port 25567 is closed, which is not the same as UDP port 25567. And MC server uses UDP for the "query" feature.

Consider these nmap command lines for reference:

## Probe UDP port 25565 -- default port for the "query" feature
% nmap -sU -pU:25565 minecraft-server
25565/udp open|filtered unknown

## Probe TCP ports 25565 and 25575 -- the usual Minecraft client port
## and default RCON port
% nmap -p25565,25575 minecraft-server
25565/tcp open  unknown
25575/tcp open  unknown
share|improve this answer
I'd be very careful calling anything 100% accurate, especially over a loopback address. – user56 Feb 18 '12 at 23:02
@arda I can't find any way in which the loopback network interface's special implementation could leak through the socket abstraction. Until someone proves this point wrong, I'll stand firm about 100% accuracy. – ulidtko Feb 20 '12 at 7:15
One example would be a firewall directly in front of the server. – user56 Feb 20 '12 at 16:38
Let's keep it civil and friendly, please :) – agent86 Feb 22 '12 at 18:54
What I said was is that over a loopback address, nmap would not be 100% accurate. Over a loopback address, nmap can only access the server if it is launched on the server. So yes, it needs to be used properly, ie. not over a loopback interface. – user56 Feb 23 '12 at 16:05

First of all, you seem to be checking for open ports with nmap, which isn't 100% reliable (especially when connecting to the loopback address, which your server might not necessarily bind to) On my rcon-enabled server, the rcon port appears to be closed according to nmap, but works fine. A better way to check is using netstat ("netstat -an" works equally well on windows CMD and *nix-based systems) which should show [::]:25575 as "listening"

Have you tried using the RCON/Query utility to query the server? remember to try both console (25575 by default) and remote query (25565 by default. You've changed yours to 25567, which really shouldn't matter, but you might consider changing it back, just to be sure.)

If you still can't connect, does the console indicate rcon is enabled when you start the server like so:

CONSOLE: Default game type: 0
CONSOLE: RCON running on

If so, what happens when you open a telnet session to your servers IP (preferable not the loopback address), port 25575? You should get a hanging blank window (as opposed to a "connection closed"/"connection refused" message) and an entry in the server console along the lines of "Rcon connection from: /"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.