Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just installed Bukkit server. I have three plugins: Essentials, WorldEdit, WorldGuard. I have configured permissons so that users have all WorldEdit and WorldGuard commands available:

- 'worldedit.*'
- 'worldguard.*'

I noticed it doesn't work if users aren't OPs(You don't have permissons to do this), but ops can use these both plugins. But I saw on other servers that non-op claimed their regions. How to allow users to use these commands if they aren't OPs?

share|improve this question
    
Could you provide slightly more information? What Permissions plugin are you using? –  Jake King Jan 16 '12 at 0:18
    
@Jake King Essentials –  Little Helper Jan 16 '12 at 11:45

1 Answer 1

I'm not sure if you still have this issue, but bukkit has removed wildcard support on permissions.

Bukkit has an in house permissions engine, but needs a plugin to tell it which users have which permissions. The in house permissions engine does not support wildcards and it doesn't matter which permissions plugin you have installed.

Learn to use parent/child permissions and groups.

Read http://forums.bukkit.org/threads/permissions-faq.25080/ for more details, it is under the "for everyone" spoiler.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.