Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm not sure when did this happen, but all of sudden I cannot use the console command moveto and placeatme.

I realized this when I'm trying to summon a dragon with player.placeatme EAFB4, it's just not appearing. The same happens when I'm trying to move myself to Lydia using prid A2C94 then moveto player.

I have tried summoning/moving to other NPCs but it's still doesn't work.

But oddly when I tried it on another save file (different character) it's working perfectly.

Any help here? :/

After several tries, I have found something.

They are still spawning. But instead spawning next to me, they are spawning to somewhere below the Riften Thieves Guild (The Ragged Flagon).

I don't know why is it happening. I discovered it when I clicked my character (0000014) and then typed moveto player in the console command. It teleported me to the below Riften Thieves Guild. Here are some screenshots to illustrate what I mean:

Example 1

Example 2

Example 3

Example 4

The Riften Guard and Whiterun Guard I've summoned earlier also seem to appear on that place. I tried summoning other NPCs using the player.placeatme again, and yup. They do appear on the Ragged Flagon.

Anyone knows why is it happening? :/

share|improve this question
Are you carrying too much stuff? – DrFish Jan 8 '12 at 6:37
Yes, I'm always carrying too much stuff. The command still worked earlier, but yesterday I just realized it didn't work anymore. – deathlock Jan 8 '12 at 6:59
Do you have any mods installed? Did you try it without any mods running? – Diskilla Jan 8 '12 at 7:21
I have many mods. I'm not sure if mod is the cause, as in another save file (with the same mod running), I can perfectly use those console commands. – deathlock Jan 8 '12 at 8:38
What is the result of GetInCellParam <ID of Riften cell> 14 while you are physically elsewhere? – Snailer Jan 8 '12 at 21:59

PlaceAtMe will create a copy of the NPC.

Instead, open the console and select the NPC with your mouse:

  • If you don't know where it is type prid XXXXX (where XXXXX is npc refId)
  • If you don't know the refId you can either:
    • save your game, load a previous save, select the NPC and write down the refId
    • locate it by searching one of the Skyrim wikis (like Wikia)
    • type help witch gives you the *base* id and you need to convert that to therefId`.

Then, type moveto player. This will only work if npc is alive: if it isn't, first type disable then enable then resurrect 1.

Alternatively, if you want to go to the NPC, type player.moveto XXXXX, where XXXXX is the NPC refId.

share|improve this answer
A heads-up on the placeatme command: "Using this code will instantly summon an instance of an object or NPC at your position. Not recommended for named NPCs. This code uses the Object (base) ID and not specific reference ID as it is creating a new instance of that object/actor in the world; using it with named NPCs can result in duplicates unless the original was somehow removed." - Use the prid <RefID> and moveto player commands whenever possible, instead. – galacticninja Sep 19 '12 at 9:24

Use Player.PlaceAtMe <BaseID> [amount] to place/spawn an item or actor object next to the player. The [amount] is optional. E.g., Player.PlaceAtMe AED40 5 spawns 5 "Adoring Fans" next to the player. This only works with NPC, creature, and item IDs.

Player.MoveTo <refID> Teleports you the to the object associated with the RefID. This also only works with NPC, creature, and item IDs.

If you want to move an object to the player, use <refID>.MoveTo Player. E.g., Moving Lydia to the player would be A2C94.MoveTo Player.

You can look up an object's base/ref ID here.

share|improve this answer
Sorry, that was I meant. I mean placeatme not moveto (for spawning item/actor). And yes, that still does not work. – deathlock Jan 8 '12 at 6:58
up vote 0 down vote accepted

OK I have realized that everytime I sell something to a merchant NPC... my coordinate CHANGES along with my sold items. I don't know precisely which item done this, because it just changes with every items.

The first time was in Riften. Then it happened in Markarth. Then in Windehlm. Then in Solitude.

Though it seems this problem never happen in outdoor, always in walled town. Not sure why is this happening. Should I open a new question?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.