Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have encountered the now-infamous "Forever Mourning" bug in Skyrim. The "Forever Mourning" bug is encountered after completing "Blood's Honor" (where you kill the witches for their heads, for the lycanthropy cure), you return to Jarrvaskr to see the Silver Hand had attacked the area, and inside the building Kodlak is dead. You turn in the quest to Vilkas, but for whatever reason he doesn't give you the next quest in the line, "Purity of Revenge". Instead, he ends up going into "busy" mode (where you can't interact with him) and everybody is "forever mourning" the attack and the loss.

I haven't cleared Driftshade Sanctuary or completed the "Find Helm of Winterhold..." miscellaneous quest. What should I do?

I've heard that I should get the Helm without killing any enemies inside Driftshade (using Invisibility potions and such), then wait 32 in-game days, then return to Jorrvaskr. Is there another way? How can I get around this bug?

I am playing on the PS3.

share|improve this question
5  
What is the bug exactly? –  jmfsg Jan 9 '12 at 13:21
1  
Sorry, I should have clarified. It's after completing "Blood's Honor" (where you kill the witches for their heads, for the lycanthropy cure), you return to Jarrvaskr to see the Silver Hand had attacked the area, and inside the building Kodlak is dead. You turn in the quest to Vilkas, but for whatever reason he doesn't give you the next quest in the line, "Purity of Revenge". Instead, he ends up going into "busy" mode (where you can't interact with him) and everybody is "forever mourning" the attack and the loss. –  TerranRich Jan 9 '12 at 14:13

4 Answers 4

up vote 3 down vote accepted

Nope, there is currently no other way, as this one was already difficult enough to come up with. Even on pc, there is no way to use the console to work it out. It is probably what you already found, but I will add it anyway in case someone else is looking for it:

According to The Elder Scrolls wiki:

Solution #1 - For adventurers who have not cleared Driftshade Refuge or completed the quest to find the Helm of Winterhold.

You may get the bug if you have the quest to retrieve the Helm of Winterhold for the Jarl of Winterhold, under misc quests, but have not completed the quest to retrieve the Helm. Load up on invisibility potions and sneak through the Refuge (killing no one), retrieve the Helm, and return it to the Jarl. Then return to Whiterun and Vilkas should give you the next quest, Purity of Revenge.

NOTE: You don't need to sneak or use invisibility potions in Driftshade Refuge. I ran through full speed ignoring everything until I got the helm and ran out. Turned the quest into the Jarl and THEN went to kill the witches. This wont work if you have already killed the witches and got the message to return to Kodlak. As long as you do NOT talk to Vilkas and finish Blood's Honor, you can repair the glitch in this fashion. -Correction- this CAN be done if the witches have been killed already and you HAVE NOT returned to Whiterun. Sneak through to retrieve the helm and return the Helm of Winterhold to the Jarl of Winterhold in order to complete the quest. After the quest is complete make your return to Jorrvaskr, and Vilkas should give you the next quest, Purity of Revenge. (XBOX). Confirmed x2 on Xbox 360. ** This also worked on PS3, I was detected twice inside Driftshade Refuge but I hid long enough for the enemies to go back to patrol mode.

Actually, you might want to describe more accurately at which point of the Companions quest you are (for example, if you already returned to Jorvasskr or not)

share|improve this answer
1  
Well, I would advise you to try the above technique then; if you don't have enough invisibility potions (quite rare) and are not a thief character (and I suppose you don't have a save right before killing the witches..?), you can also try forcing your way running through the dungeon. Anyway, let's hope someone passing by has actually encountered this bug, which seems quite common. –  Cristol.GdM Jan 9 '12 at 14:55
1  
Just to be sure, you have 30 hours after observing there was a bug, and they were stuck in constant mourning? For this kind of game, it's better to solve a bug as soon as you observe it, or else it gets worse (just so you know next time). But yes, I think what you just said is what you need to do; you need to avoid triggering any enemy, pick up the helmet, bring it back, and go to Jorvasskr. And make a hard save at every point (before entering the dungeon, before picking the helmet, before leaving, giving it back, going to Jorvasskr, etc), so you can try different things if necessary –  Cristol.GdM Jan 9 '12 at 19:30
1  
I didn't realize it was a bug until 30-40 hours after observing it. I originally Googled what the next quest after "Blood's Honor" was, because I finally decided after doing various other miscellaneous and other questlines outside of the Companions' questline, that I should finish the Companions' questline so I could marry Aela. I hardly went into Whiterun or near Jorrvaskr other than to turn in "Blood's Honor" and then 30-40 hours later when I realized there was a bug. But I'll try the above (with hard saves, of course), and hopefully it'll work. :) Thanks! –  TerranRich Jan 11 '12 at 1:31
1  
I waited as far away as I could, for 33 in-game days (just in case). No change, other than Vilkas no longer constantly sleeping, but instead walking around. He still doesn't give the next quest, though. Oh well. Next time I play the game with a different character, I'll at least know better. :) –  TerranRich Jan 16 '12 at 5:05
1  
For anybody following this, the recent 1.04 patch has fixed this bug (at least for me and others in my exact situation). :-D –  TerranRich Feb 15 '12 at 18:58

Patch fixes

This issue should now have been fixed as of the official patch v1.4 (2012-02-05) and v1.9 (2013-03-04). Related changelog:

[v1.4] Blood’s Honor will start properly if you visited and completed Driftshade and an extended period of time passes before starting the quest.

Before those patches, the Unofficial Skyrim Patch (USKP) had a fix for that issue. Related changelog from v1.3.0:

If Helm of Winterhold (Favor158) has started, Purity of Revenge (C05) could not start after Blood's Honor (C04) due to the location alias being reserved. The location alias for Driftshade Refuge has now been marked to "allow reserved" and "allow cleared" which enables Purity of Revenge to begin. (Bug #8200) [Official Patch 1.9]

The above USKP v1.3.0 fix has now been marked as fixed by the official patch v1.9. It has not been documented in the official patch changelog.

Possible manual fixes

(from UESP wiki's "Purity of Revenge - Bugs" article)

  • If Driftshade Refuge has already been cleared, this quest cannot be started normally without a workaround. Before you begin Blood's Honor, wait 30 in-game days after you have cleared Driftshade Refuge to allow that dungeon to reset (you will have to revert to a slightly earlier save to do this). This should allow Purity of Revenge to begin normally upon completion of Blood's Honor. An easy way to check if the dungeon has been reset is to check the doors--if they have all been shut, it is reset (e.g., if the formerly barred door is barred again).
    • (PC only) The console may aid in fixing this. Click on Vilkas and use the disable and then enable commands, then use setstage c05 0 and talk to him.
    • (PC only) Another method that has worked is to reset the interior of Driftshade Refuge by typing ResetInterior DriftshadeSanctuary01 into the console. Then go and visit Driftshade Refuge and confirm that it is reset. It should be populated with Silver Hand fighters. Do this before talking to Vilkas, and when you do speak to him the next quest may start.
  • If Blood's Honor has already been completed and this quest won't begin because the Helm of Winterhold miscellaneous quest is active, it is possible to proceed through Driftshade Refuge without killing anyone (use stealth, fear or invisibility as needed) and take the Helm of Winterhold from the chest at the end. Once the Helm is returned to the Jarl of Winterhold to complete that quest, return to Jorrvaskr and the Purity of Revenge quest will begin.
    • (PC only) Another possibility is to complete the Helm of Winterhold quest by typing setstage favor158 20 into the console before talking with Vilkas.
  • (PC only) Should the "Retrieve the Helm of Winterhold" quest pose a repetition problem. Simply go to the Jarl Korir, take the quest one more time and enter setstage favor158 20 on the console. This quest shouldn't be a problem anymore. On the console, proceed by tapping ResetInterior DriftshadeSanctuary01. Then return to Vilkas and on the console, enter setstage c05 0.
share|improve this answer

Here is what you can do (I have only tested this on the PS3).

Return from a save that is nearer to the witches' cave (the latest save before getting the heads).

Wait 32 ingame days there (must be before getting the head)

Complete the quest and continue on Skyrim.

AND REMEMBER: You were waiting while already in Jorrvaskrr. You must wait BEFORE getting the witches' heads'. This is the only way to solve that bug in PS3 (probably works on other consoles too, not tested though.)

share|improve this answer

The bug does (can) happen if you've completed the Winterhold Helm quest, before getting Blood's Honor (happened to me). One of the triggers for the bug is apparently having Driftshade Refuge -cleared-, which makes Purity of Revenge not pop.

That's why one of the workarounds is to retrieve the Helm without killing any NPCs. Luckily I have a hard on 'Striking the Heart', the prior Companions quest. Hopefully with a 32 in-game day wait the Refuge will have respawned and Purity of Revenge will pop.

share|improve this answer
    
Make sure to wait before getting the witches heads' for Kodlak. There is no need of waiting before starting Blood's Honor. Cy –  user18905 Jan 24 '12 at 23:31

protected by Community Feb 9 '12 at 4:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.