Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm going back with some friends to play through the original Diablo and it has been looking really oddly colored. It either has full on technicolor:

Screenshot of Diablo with the regular colors replaced with garish alternates

Or just random color particles on the edges of objects. Does anyone know of a way to fix this bug? I'm trying to run it on a 64 bit Windows 7 machine.

share|improve this question
1  
    
At first I was like "wuh.." then I lol'd. –  Rapida Jan 11 '12 at 22:07
add comment

2 Answers

up vote 8 down vote accepted

Crazy as this sounds, you can kill explorer.exe from the task manager once you have Diablo open, and it will fix your technicolor issues. This seems to work with a lot of other older games in Win 7 64-bit.

share|improve this answer
4  
you also might try running it in XP compatibility mode, running it in 256 colors, disabling visual themes and/or disabling desktop composition; all through the Compatibility tab of the file/shortcut properties. –  Xantec Jan 11 '12 at 3:44
    
I actually tried to do XP compatibility mode, but it only worked for about five minutes. When I hit a load screen it technicolored again. So far killing explorer has worked though. –  Rapida Jan 11 '12 at 4:04
add comment

Edit Try this solution from here

  1. Install the game. (if already installed please backup your saved games, uninstall the game, delete the files remaining in the folder that was installed and install the game again)

  2. Download the update 1.09 from Blizzard Support.

  3. Once downloaded run the update as administrator. (remember that the game disc must be in the drive)

  4. Download this file DiabloFIX.zip.

  5. Extract and copy the file to the game folder.

  6. Edit your game shortcut In Games Explorer: First open Games Explorer and wait until the game update the stats, now close and go to C:\Users\username\AppData\Local\Microsoft\Windows\GameExplorer sort the folders by date and it should be the one down the GamesBoxArt folder, open the folder {#-#-#-#-#}>PlayTasks>0 right-click in the game icon and go to properties, replace the .exe for .bat at the end of the target path or In Start Menu: Go to All Programs>Diablo> right-click in the game icon and go to properties, replace the .exe for .bat at the end of the target path

  7. Make sure that the game is not setting to run in compatibility mode or disabling settings.

My original answer was for Diablo 2. My mistake. Sorry. Edit Also I had to disable desktop composition and run the game in Windows XP compatibility mode. HTH.

This happened to me and my solution was to use the 3Dfx Glide Library on Windows 7. This link was able to help me solve my issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.