Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was playing dota 2 beta today. A game ended and I went afk without returning to the main menu. When I returned I was at the menu with "game in progress" but no buttons to return to or leave the game. I have turned off steam, restarted dota, left steam off for a while, tried to have someone else start a group and start a new game, and tried to spectate a game. None of these things have worked.

What to do?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I think you are referring to the "Game is finished" message, so, there are two things you can do:

Wait

This problem is known to vanish after some time, but the time itself is unknown.

Spectate a game (until the end)

A more definite solution is to spectate a game until its end, and then click on the Finish Game button on the post game screen. Just watching for some time won't cut it, you have to watch until the end.

Post game screen

share|improve this answer
    
Thank you, spectating until the end fixes this problem. –  Brent Jan 13 '12 at 20:59
    
@Brent You're welcome! Glad to know it's fixed. –  Thiago Silveira Jan 13 '12 at 21:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.