Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've managed to get the L4D2 dedicated server running on Linux (vanilla Debian 6), it works, but there's one major fault.

The server won't read any configuration files. It always ends up with

Setting breakpad minidump AppID = 550
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
exec: couldn't exec server.cfg
Connection to Steam servers successful.
   VAC secure mode is activated.

and no setting applied. (server.cfg is in cfg directory, I've tried the +exec flag)

I would be very grateful for any advice.

share|improve this question

2 Answers 2

You need to put all .cfg files into the \cfg folder in the main left4dead2 directory

share|improve this answer

Check for permissions.
The server would need at least a "644" permission for the user you run the server with.

In case the user permissions are screwed up by anything, chmod +x "/.../cfg/server.cfg could help out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.