Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Launch:

java -jar minecraft.jar

Exception after login:

Exception in thread "Minecraft main thread" java.lang.UnsatisfiedLinkError: /home/fabianhjr/.minecraft/bin/natives/liblwjgl.so: /home/fabianhjr/.minecraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1928)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1825)
at java.lang.Runtime.load0(Runtime.java:792)
at java.lang.System.load(System.java:1059)
at org.lwjgl.Sys$1.run(Sys.java:69)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
at org.lwjgl.Sys.loadLibrary(Sys.java:81)
at org.lwjgl.Sys.<clinit>(Sys.java:98)
at org.lwjgl.opengl.Display.<clinit>(Display.java:132)
at net.minecraft.client.Minecraft.a(SourceFile:180)
at net.minecraft.client.Minecraft.run(SourceFile:648)
at java.lang.Thread.run(Thread.java:722)

So far I have tried the following:

export LD_LIBRARY_PATH="/opt/java/jre/lib/amd64"
java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame

http://paste2.org/p/1849276

I am using openJDK 1.7.0, 64 under Fedora 16.

share|improve this question
    
Can we please get some more information about your system? Especially architecture and installed Fedora-Version (32 or 64-bit?). This looks like a problem between 32 and 64-bit, like your OS is 64bit but installed java 32bit, or vice versa or similar. –  Bobby Jan 22 '12 at 15:20
    
F16(64 Bit), openjdk-1.7.0* for x86_64 –  Fabián H. jr. Jan 22 '12 at 15:25
2  
AFAIK openJDK is not supported by minecraft. Try with Sun's JDK. –  Maerlyn Jan 22 '12 at 15:28
    
It could be that something went wrong while updating, you could try to get the lates lwjgl binaries yourself for your architecture and try with those. –  Bobby Jan 22 '12 at 15:41
    
Not really to do with the question, but are you the LinuxOutlaws Fab? Given the confluence of Linux and Minecraft, it seems likely :D –  SaintWacko Jan 23 '12 at 16:44
show 2 more comments

2 Answers

up vote 8 down vote accepted

OpenJDK is not supported by Minecraft. Install Sun's JDK.

share|improve this answer
add comment

For what it's worth, a workaround to continue using OpenJDK is to copy the 64bit native libraries over their 32 bit counterparts, as the issue here is that it is loading the 32bit versions when it expects the 64bit version.

i.e. Copy every whatever64.so in your bin/natives folder over the whatever.so file. However, you will need to do this every update.

You may also need to download the latest LWJGL, depending on your Java version

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.