Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've purchased a graphics card lately, a Nvidia Geforce 210, with awesome features. The only downside is my RAM (512). Every kind of video requirement I can max out with this graphics card but my RAM is terrible, but I have to admit new games such as HL2:EP2, DOD:S, HL2, Dark messiah, Minecraft, they all run smooth and at an ideal 60+ framerate at a time.

However, I tried to play TF2 on steam, since it's free, I defragmented it's cache files via steam and I added DXLEVEL 80 and I even lowered my settings bellow the ones recommended for my system, yet I am experiencing TERRIBLE overall performance in TF2.

  • Waiting about 5 minutes for the game to start up, and huge lag in the main menu
  • In-game it takes about 30 minutes of play-time for the game to run relatively smooth
  • When I run into groups of 5+ players the game lags terribly
  • I have no ping/network issues
  • The game is running in windowed mode at lowest resolution

I did a test to see if my game can run it, and it's above the minimum required specifications, But it is absolutely unplayable, Why is the performance so bad?

My PC Specs:

  • OS: Windows XP Professional.
  • CPU: Single-Core Processor.
  • Graphics: Nvidia Geforce 210.
  • RAM: 512 MB
share|improve this question
1  
im not putting this as an answer because im not really 100% on how all hardware works anymore. But RAM is important. always was always will be. I'm glad your running all those other programs fine but that was more luck and probably what i call cross-over performance. (when overcompensating in one area helps a under-compensated area) However, its likely your low ram has finally caught up to you. RAMS cheap, buy more. –  Ender Jan 22 '12 at 18:32
1  
I could be wrong, but doesnt windowed mode cause more struggle on the system? try full screen. –  Doomsknight Jan 22 '12 at 19:06
1  
1  
@ThePlan: Both questions are about low performance in TF2? –  CruelCow Jan 22 '12 at 19:45
4  
@ThePlan: I'm sorry for trying to help you solve your problem. Won't happen again. –  CruelCow Jan 22 '12 at 19:49

2 Answers 2

up vote 6 down vote accepted

I'm unsure why you added DXLEVEL 80.

512Mb of RAM is very small; it is clearly the bottle neck in this case.

You do state though that the other noted games run fine. It is possible that with all the content that is in use at the same time when playing TF2 that your RAM is just not capable of holding it all (and TF2 has a lot of content, such as hats).

As for the shown minimum requirement, maybe due to the steady increase in the size of the game since release and all the addition new items/content, the stated requirement is actually no longer realistic.

share|improve this answer
1  
Perhaps that's it, it hasn't changed in years :/ –  Bugster Jan 22 '12 at 19:29
1  
@ThePlan : its worth noting that you stated that 512 was the minimum. And rarely, graphical performance wise, is the minimum going to give you great results. Its the minimum required to run the program, not play it realistically. Playing it realistically would the the 'recommended' requirements. –  Ender Jan 22 '12 at 20:04

I don't know if you've tried these options, but I'm putting them here because this is what I do on my laptop to achieve a decent FPS when playing Source games on the train home. (like TF2, Left 4 Dead etc).

  1. Kill unneeded applications whilst playing games
    • Music players
    • Auto updaters (Java and Adobe for example)
    • Antivirus scanners
    • Explorer
    • Open Web browsers etc.

Note: You can remove selected items from your startup list if you find you're constantly disabling them from your taskbar/killing them using the task manager.

  • In Windows 8 you can disable startup apps from the Task Manager, in the Startup Tab.
  • In Windows 7, Click Start, type msconfig and hit enter (on Windows XP, open 'Run...' and type msconfig there)
  • In the Startup tab, disable applications you don't want to start when you boot up


2. Increase the size of your paging file

Normally, Windows defaults your paging file to 2x the size of your RAM, which in your case would be 1GB. This paging file sits on your hard drive and acts as 'extra' RAM, albeit a lot slower than actual RAM.

Increasing it is a stop-gap measure if you absolutely cannot afford more RAM. To do this:

  • Open System in Control Panel.
  • On the Advanced tab, under Performance, click Settings.
  • On the Advanced tab, under Virtual memory, click Change.
  • Under Drive [Volume Label], click the drive that contains the paging file you want to change.
  • Under Paging file size for selected drive, click Custom size, and type a new paging file size in megabytes in the Initial size (MB) or Maximum size (MB) box, and then click Set.

Try increasing it to 2GB, and see if that helps.

share|improve this answer
    
A paging file will just hurt performance, as hard drive reads are much slower than RAM. –  Richard J. Ross III Apr 19 '13 at 4:49
    
@RichardJ.RossIII - As I've said, it's a stop-gap measure. However, only having 512MB of usable memory hurts more. I've made it clearer that it's not a fix-all solution. –  Robotnik Apr 19 '13 at 4:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.