Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently began playing Oblivion again, after a long hiatus. I'm doing so on my MacBook Pro, in a Parallels Windows Server 2008 VM (6 GB of RAM). The MacBook itself is the late 2011 17" Pro model, upgraded to 16 GB of RAM.

Everything in Oblivion, including the mods I've installed, works great -- except that I cannot bring up the console. The tilde (~) key is nonfunctional. That said, so far Oblivion is the only program on the Windows side to not recognize it. In Notepad, Visual Studio, Wordpad, etc., it works. Just Oblivion. (Admittedly, Oblivion is the only game I have on the Windows side here.)

Is there some way to open the console without the tilde, or failing that rebind the "open console" command via a configuration file, or failing that at least use a config file to display fps? (Which is actually the only reason I want the console right now.)


Total aside: The obvious answer to most of us would be to run Oblivion (and Windows in general) in Boot Camp. Not an option. Long story.


Update: I should have mentioned two things: 1) bAllowConsole is 1 and 2) I have no idea where to find the § symbol that everyone says is a workaround. (I have a US keyboard layout; that symbol is not on the face of any of my keys.) And again, the tilde works in every Windows app, just not -- I'm guessing -- games.

share|improve this question
    
I've Updated my answer to reflect the location of § on a MacBook keyboard –  JohnoBoy Jan 30 '12 at 19:54

2 Answers 2

up vote 6 down vote accepted

It's possible that your bAllowConsole setting in oblivion.ini has been disabled; it should be set to 1 to allow you to use the console.

Failing that, there are mods (of course) that add a spell that opens the console, add a ring to open the console, or let you change the console keybinding.

share|improve this answer
    
Chances are good that a mod which enables it via a spell or alternative keybindng is what I'll end up going with. –  John Rudy Jan 30 '12 at 23:15
    
Went with the spell. That works nicely. Added bonus: It games my alteration skill. ;-) –  John Rudy Jan 31 '12 at 1:13
    
Also, there's the Ring of Console mod: "This mod adds Ring of Gods to your inventory. Equipping it opens the console. If you want to open the console outside inventory, assign the Ring of Gods to a hotkey and equip it outside the inventory using the hotkey." –  galacticninja Jan 31 '12 at 7:50

You share the tilde issue with many developers on the Mac who use parallels, there is a workaround, documented here:

To type a tilde (~) in a windows 7 vm on parallels with a macbook pro you press: SHIFT + §

The § key is the key left of 1 on the number row, shared with a ± sign

share|improve this answer
    
For me, that's the grave accent and tilde. Yeah, I know. :) –  John Rudy Jan 30 '12 at 23:14
    
There is no such sign. I am having the same trouble with my asus that has windows vista –  user49144 May 26 '13 at 17:41
    
@Bob the § key is available on Mac keyboards, which the question applies to. Thanks for the downvote, though. –  JohnoBoy May 26 '13 at 21:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.