Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Using the built in replay editor, replays look fine (as they do in gameplay):

But after saving the replay to a file, they come out very dark:

Note it doesn't look too bad here since it's small, but bring up the fullsize and you'll see the difference. Also here's the full video to see the darkened issue:

This seems to be a reoccurring problem for people: http://forums.steampowered.com/forums/showthread.php?t=1875348

What could be the cause?

Win7 64bit
6GB RAM
i7 CPU
ATI Radeon HD 5800
1400x900
share|improve this question
    
It sounds like the gamma in-game and the gamma for rendering don't match, although I don't have enough experience with replays to help further than that. –  agent86 Jan 30 '12 at 14:24
    
The issue is there's no gamma or lighting setting for rendering. –  Zeno Jan 30 '12 at 18:40
    
Is the cloaking effect supposed to give you rainbows in your skin? Is the dead ringer supposed to be pink? Does removing the skin help? (Also, damn, that's quite a long capture time on a last point right outside the enemy spawn.) –  badp Feb 13 '12 at 13:16
    
With no mods, the problem still happens. –  Zeno Feb 15 '12 at 17:21
add comment

2 Answers 2

up vote 2 down vote accepted

Per Steam support, this (the codec part) solved it:

Thank you for contacting Steam Support.

You may wish to select a different rendering output codec.

Note that video compression techniques often rely on reducing the range of colors and brightness used in a frame.

Using a different codec may create better results.

You may also try increasing the Brightness Levels in the in-game Video options menu prior to rendering the replay.

For more information and options, please refer to the TF2 Wiki replay article linked below.

http://wiki.teamfortress.com/wiki/Replay

If you have any further questions, please let us know - we will be happy to assist you.

share|improve this answer
    
Could be useful (for posterity) to specify which codec you were using, and which you switched to that fixed it. –  The Annoying Pyro Apr 11 '12 at 17:46
add comment

The same forum post you linked to has a possible solution by using windowed mode.

Other than that, it could be a driver issue - try installing the latest & greatest ATI drivers.

Also, if you are running dual video cards try disabling one of them. Dual GPU setups can exhibit weird behaviors.

share|improve this answer
    
I'm already running (borderless) windowed mode and have the latest drivers. –  Zeno Feb 7 '12 at 18:28
    
Sorry I couldn't help. –  Ben Feb 8 '12 at 4:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.