Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I thought maybe this was just me until I saw an unanswered post on the Bethesda - Skyrim forums: loose sky reflection.

Note that this problem only shows up if you've modded Skyrim.ini to reflect the sky by adding bReflectSky=1.

The problem is that the sky appears 'detached' from the rest of the world when reflected in water. Rather than it being fixed, it moves with the camera (i.e. moves when the player moves in first person view.) When standing still, the reflection looks great, as well as when moving at a constant speed, but if you alternate between standing still and moving, or just tap a directional key repeatedly, alternate between walking, running, and sprinting, or even strafe around in circles at a constant speed, the sky portion of the reflection jumps around in odd, unrealistic ways corresponding to the character's velocity.

It's hard to see when the sky is just blue with some clouds, but very easy to see at night, especially if you use the "Enhanced Night" mod.

Has anyone encountered this, and does anyone know of a way to fix it? It might just be a bug that went undiscovered because by default bReflectSky is off. Or it could have been turned off by default because they couldn't solve the bug, who knows.

I'll work on some demonstrative screenshots.

Confirmation and Demonstration

I had someone else email me that has been working with the same problem:

I actually did make a couple videos and the result with the free camera in the second video is pretty crazy.

As far as I can tell the reflection only looks correct from exact point in space where the players face is when standing still. It's not actually tied to the camera at all; the reason the anomalies are seen is because the camera bobs up and down during running and jumping. It's even more obvious when using the TFC 1 command and flying around.

I've posted about this on the Bethesda official forums and the Skyrim Nexus to no such luck.

share|improve this question
    
I wouldn't consider it a glitch. If you have to change the default behaviour via an INI file, it was off by default for a reason. Probably more of a side effect of how the engine works. –  Alan B Feb 4 at 10:46
add comment

1 Answer

It could be a Z-Fighting issue similar to the flickering mountains glitch. If you altered the .ini to reflect the sky, I recommend going back to original config options and choosing to use the tool below instead, which has a simple checkbox for sky reflections.

If you don't have it already, I recommend getting the Skyrim Configurator: (http://skyrim.nexusmods.com/mods/814/?) It's basically the configuration .ini with an easy to use interface.

Find the options that involve fixing Z-Fighting (in red text) and maybe Water effects, it may just be that your video card doesn't like one of the water settings you have. Let me know if you find anything out! I'm curious about this glitch now.

share|improve this answer
    
Nope, didn't change anything. Guess it's not related. Disabling water effects makes it way easier to see that the sky reflection is messed up though. –  Alain May 10 '13 at 22:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.