Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have an annoying problem regarding the view distance in Star Wars: The Old Republic. It used to have a slider during beta where you could adjust the distance stuff would be shown. But now I can't find that setting.

This results in NPCs materializing near my postition. Just like Scotty beamed them down. No, it is not a respawn; it happens with all the NPCs. Best visible when moving towards big creatures like the bantha or icetromper.

Grass and flowers seem to grow as I move towards them.

Using the interfleet transport I can see the front of the space station but everything in it is drawn when I close in. This means at first I can see through the space station and have a magnificent look on the sun in the background.

How can I adjust the view distance?

  • Nvidia GTX 570
  • Driver Version 285.62
  • Windows 7 64-bit

enter image description here enter image description here enter image description here

share|improve this question
    
Try forcing the ansi-tropic filtering in your graphics drivers control panel. In the applications settings profile you can force this to be 8x or 16x which will force the game to render objects further away. –  DavidYell Feb 9 '12 at 15:47
    
@DavidYell I think you mean "anisotropic" :P –  Matthew Read Feb 9 '12 at 18:52
    
@DavidYell isn't anisotropic filtering for improoving the quality of the image in the distance and not the distance itself? I'll give it a try and tell you the result. –  Tom Feb 10 '12 at 7:34
    
@Tom Could be, it's off the top of my head! Fingers crossed! –  DavidYell Feb 10 '12 at 8:27
    
@DavidYell there was a setting in the ini-file "AnisotropicFiltering=16". So I think this is maxed by default. –  Tom Feb 14 '12 at 9:13

1 Answer 1

I did some research and found this

If you go to about page 4 you will find this post:


Great news lads! :P

I've managed to decrease draw distance... And I will show you how to do it in few simple steps!

Go to (for example on Windows 7, installed on drive C:): C:\Users\<username>\AppData\Local\SWTOR\swtor\settings (Replace <username> with yours)

In "settings" folder you will find a file called client_settings.ini—right click on it and select "Open with", then "Notepad"

My file looks like this:

Code:
[Renderer]
D3DFullScreen = true
EnableBloom = false
Height = 768
NativeHeight = 1024
NativeWidth = 1280
RefreshRate = 85
TextureQuality = 1
UseMinSpecShaders = true
VerticalSyncState = true
Width = 1024
WindowX = 0
WindowY = 0
FarClipScale = 0.3371195
PlantDensity = 14
SpeedTreeDistanceScale = 0.82336956
AllowDepthOfField = false
doShadows = false
doBlobShadows = false

[Game]
MoviesFolder = ..\..\Movies
SwtorRegKey = SOFTWARE\BioWare\Star Wars - The Old Republic

Now find PlantDensity, in your client_settings.ini, and INSERT

FarClipScale = 0.3371195

ABOVE PlantDensity on its own line. (You can also try 0.1371195 or 0.5371195, but I know that 0.3371195 works perfectly for me!)

Don't FORGET to SAVE your client_settings.ini after you add FarClipScale = 0.3371195.

After you've done that, close your client_settings.ini and right click on it -> Properties. On the bottom of Properties window you'll see a check box "Read-only". Check it! Now you should be ready to play!

I hope this helps!


This appears to be a fix for increasing or decreasing your draw distance. A little research and trial and error may have to be done to ensure you have the right setting number entered, but this seems to be an effective fix. I am not home so I cannot try it myself.

Also make sure you are displaying hidden folders, because AppData is a hidden folder.

share|improve this answer
    
Note that this, and most of the thread, is around lowering draw distance to improve performance. You will want to mess around with it some. I recommend reading the whole thread posted as some users did things a little differently. And you will also (most likely) have to change this every patch if they update client files. Hopefully they add the slider back in and add some more graphics options soonTM (so I can push my machine further). –  Adanion Feb 9 '12 at 15:09
    
Yes, this is only a temporary fix given that the slider is gone and the OP wants to edit it now. Assuming this is a big issue I'm sure the slider will perfect again. –  Emerica. Feb 9 '12 at 15:12
    
Funny thing is, I already have FarClipScale in my ini-file. It was set to 25. Can anyboy tell me why those numbers are so long? Would it make a (huge) difference using 0.34 instead of 0.3371195? How do people get to such numbers? –  Tom Feb 10 '12 at 7:42
    
I am not sure how people come to these numbers, but it seems as though FarClipScale = 3.9371195 is the maximum for this value to have effect. Anything over this is it will default to an alternate value. –  Emerica. Feb 10 '12 at 13:50
    
Also, .25 is rediculously low so that would certainly explain why things are materializing in your face. –  Emerica. Feb 10 '12 at 13:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.