Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Whenever I start up Mass Effect 2 and it tries to auto-login to my EA Online Account, I see this screen.

enter image description here

Then, I have to manually log in, and I see this screen.

enter image description here

Empty login screen. Every time. So I have to input my email address and password again. Every time. Once I do this manually, it works. However, the next time I close and reopen the game, I have to go through this entire process again. The auto-login isn't working for me.

Is there any way to get Mass Effect 2 to remember my new login information?

share|improve this question
    
Have you tried the settings? –  kotekzot Feb 21 '12 at 0:58
    
@kotekzot Can you be more specific? I don't see any related option in the out-of-game setttings, and in the in-game settings, all I can do is turn auto-login off completely. –  Sterno Feb 21 '12 at 1:36
    
Unfortunately no, I'd have posted an answer if I could, sorry. I recall EA having a tendency to burying these things in the settings. –  kotekzot Feb 21 '12 at 2:21

5 Answers 5

I thought I had this fixed, but it turns out it only made the auto-login work for an hour or two. Then it's back to the error. Leaving it here until I find something better.


  1. Start the game.
  2. Go to Extras->Options->Online and set Auto Login to EA Online to No.
  3. Exit the game.
  4. Restart the game.
  5. Manually connect to EA Online.
  6. Go to Extras->Options->Online and set Auto Login to EA Online to Yes.
  7. Exit the game again. Auto-login should work from now on.

Do not do step 6 before you do step 5. I tried that and after manually logging in it reverted my setting back to "No" instead of "Yes".

share|improve this answer
    
+1 for effort... grats! –  Steve the Maker Mar 13 '12 at 14:57
    
    
This worked for me for a day or two. Then it stopped working. Might have been complete coincidence it worked at all. –  Sterno May 24 '13 at 14:40
    
This worked for me. I'll report back if I get the same result as Sterno after a day. –  CoreDumpError Jun 9 '13 at 4:02

Saw this on the Mass Effect Wiki:

  1. In Windows 7, go to Control Panel -> Programs and Features -> Turn Windows Features On/Off
  2. Expand Microsoft .NET Framework 3.5.1
  3. Make sure that both Windows Communication Foundation HTTP Activation and Windows Communication Foundation Non-HTTP Activation are checked.
share|improve this answer
    
Did you try this? Did it work? –  ヴァイシャリ May 30 '13 at 2:12
    
@One-One: I never had this problem. However, I did go through the steps above and both WCF HTTP and WCF Non-HTTP Activation were checked already. –  C-Pound Guru May 30 '13 at 12:43

The "delete Player1.prf" answer seems to be correct in the sense that deleting Player1.prf caused the auto-login to work, at least the very next time I ran the game.

However, it is wrong in the sense that all my other settings (except graphics) were reset as a result. This includes key bindings, inverted mouse, sound volume, and automated gameplay feedback submission.

It also seemed to reset achievements, at some level; the next headshot I got popped up as 1/30 instead of one million. This made me nervous, so I restored my original Player1.prf file, and therefore can't say how well this solution works in the longer term, or what other impacts it may have.

It's worth noting that, as far as I know, the only time you need to be logged in anyway is the first time you run the game after installing one or more pieces of DLC. That is, unless you care about constantly updating your online achievement log, or whatever it is that the bioware social network tracks and displays.

share|improve this answer
1  
Hi Gryphon, welcome to Arqade. This is a Q&A site rather than a discussion forum, so "answers" should actually be answers to the original question. What you have posted is a (probably useful) comment on how well another answer worked for you, but it doesn't answer the original question. You may find that people downvote it for this reason. Once you hang around for a short while and ask and answer questions, you'll quickly gain enough rep to be allowed to leave comments like this one - which are a more appropriate place for this sort of info. –  Simon W Jan 24 at 9:54

Not that I have found.

However, DLC does not seem to require you to be online to use in Mass Effect 2. I was able to simply disable the EA Online automatic login, and I was able to play the game with no problems (including all of the Character/Mission DLC, but none of the Outfit/Weapon DLC, on the PC).

share|improve this answer
    
Just to clarify, are you saying you have the same problem and don't think there is a fix, or just that you haven't really looked into a solution but wanted me to know I didn't need it for the DLC? That DLC thing is nice to know, btw, so thanks for that. –  Sterno Feb 23 '12 at 2:34
    
When I had this problem, I looked for a fix. This was the only solution I found to the symptom (the annoying pause and error screen while loading the game). I did not look exhaustively, however, because the symptom was gone. –  ILMTitan Feb 23 '12 at 6:53

Exit game

Delete this file: My Documents\BioWare\Mass Effect 2\BioGame\Profile\Player1.prf

Start the game and give it you login info

It is now saved.

This file does not effect anything else, all your other settings and saved games will still be there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.