Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a superflat test world, where I was going to do experiments with mob farms. Except it seems that for some reason, everything is lit up, as if I were building it out of glass. (it gets dark once it turns night though). Everything is perfectly normal in my non-superflat worlds...

Daytime: Completely enclosed room. Should be totally dark, right? Apparently not.

Nighttime: Enclosed room at night - as you can see, there is a discrepancy.

Any ideas? Or is this probably a bug?

share|improve this question
4  
Screenshots are your friend :P –  user9983 Mar 6 '12 at 1:55
    
I'm not able to reproduce with a smooth stone cube in superflat creative mode. –  Resorath Mar 6 '12 at 2:05
    
I saw this for a few minutes in SMP today. –  John the Green Mar 6 '12 at 2:10
    
I saw this when I was digging a tunnel between the grass and bedrock, in 1.2.3 (but the world was created in 1.2pre). However, it fixed itself when I removed and replaced the ceiling grass, so that's a different case. –  Kevin Reid Mar 6 '12 at 13:11
    
I've tested this over and over again by making 1x2 rooms out of stone around me, and making sure that every block around me is in place... but with the same result. –  Unionhawk Mar 6 '12 at 14:14
add comment

2 Answers 2

up vote 3 down vote accepted

If you are running on preview 12w07, lighting was not calculated properly, this was fixed in a later version. If not it may be that it was generated in this preview and has the same issue. Try placing a light source to force a lighting update.

share|improve this answer
    
I'm running Minecraft 1.2.3. The world was created whenever they added superflat (1.1?), and converted to Anvil in 1.2, I think. (it was either 1.2 or 1.2.2, or whatever; not 1.2.3), and I have never used a weekly build. –  Unionhawk Mar 6 '12 at 14:10
    
have you tried placing then removing a torch? even if this was not the cause it should force a lightning update. at any rate, it seems that lighting is calculated from daylight, which was a known bug in 12w07 (the first release of anvil). –  legacy Mar 6 '12 at 16:38
1  
For some reason, the ceiling isn't blocking out the light. Replacing it is working (the torch idea didn't though...) –  Unionhawk Mar 6 '12 at 22:49
    
It looks like a bug... a weird one at that, though. –  Unionhawk Mar 7 '12 at 0:41
add comment

I believe there is a lighting option when you click: esc

Brightness I think? Maybe yours is too high.

share|improve this answer
    
This does not change it; I'm running with highest brightness all the time. It can still get to light level 0. –  Unionhawk Mar 12 '12 at 11:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.