Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Wondering if anyone else has seen this. I just got Republic Commando on steam, and when I run it strange things happen. I get a black screen for a minute or two before the first splash video plays. That plays very choppy, then it sits forever before getting to the main menu.

The menu works fine, but when I try to start a game the loading bar goes to full and then it just sits there indefinitely.

EDIT: Sorry, meant to include the specs:

Windows Vista Intel i7 2.67 GHz 6 Gig RAM NVIDIA GeForce GTX 260

Republic Commando is an older game, and only requires a Pentium 3 1GHz or better. I've played this game on older hardware and it ran fine. There's no reason it should have performance issues on my current machine.

share|improve this question
1  
What are your machine specs and how do they compare to the minimum and recommended specs on Steam? –  ChrisF Aug 15 '10 at 21:29
    
The version of windows you're running might be important too, could you also please include this? –  alexanderpas Aug 22 '10 at 8:44
    
For what it's worth, it doesn't run on my new desktop (Windows 7 x64) either. –  Macha Aug 24 '10 at 12:05
add comment

4 Answers 4

I had a problem with my Windows 7 machine and running this game also it wasnt running through steam but it would always crash when trying to load into a level.

Try this, turn BUMP MAPPING in the in-game graphics options to Low and see if that work.

share|improve this answer
add comment

as the person stated above with the bump mapping, yes that is usually the main reason the game crashes on newer machines. The game ran on unreal 2 which didn't actually have bump mapping as a feature and the guys at nvidia worked with lucasarts for a work around, There is a bug with video cards that came out after the geforce 7800 because the work around never was carried over. Anything other than low and the game crashes upon loading. I myself have had the same issue. It's a shame because when it came out the game looked really good but rather be able to play it on low bump settings than not at all.

share|improve this answer
add comment

If you are running Windows 7:

Try running it in compatibility mode:

You can access Steams executable in this folder: Path for Steam Folder\steamapps\common put a shortcut on the desktop and modify that shortcut to run in the executable in compatibility with another OS.

Secondly if this persists you can tone down your GPU for that specific game. Just go in the Nvidia Panel, 3D Settings, choose your game and start modifying.

share|improve this answer
    
I'm rung this in Vista sadly. I can try compatibility mode there though. –  Herms Sep 3 '10 at 2:43
add comment

Have you checked the game's integrity with Steam? Sometimes a file will be corrupted in download if downloaded with multiple other files at the same time, and if that happened, you can check the game's files with Steam. Here is how to do so:

  1. Load Steam
  2. From the Library section, right-click on the game and select Properties from the menu.
  3. Select the Local files tab and click the Verify integrity of game cache... button.
  4. Go grab a cup of coffee, wait for the process to complete.
  5. Once the process is completed, the Check Window will automatically exit. Congratulations, you just verified the integrity of your game!

I have done this multiple times with TF2 because some textures were messed up. If something is wrong with your installation of the game, Steam will prompt you to reinstall it, and then your problem should be solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.