Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

One of the things I like most about Rayman Origins is that each level has a "rhythm" that lends itself perfectly to speed runs. This is extremely evident on the levels where you try to collect teeth, as you usually have to constantly run through those levels or die.

Lately, I've tried getting the tooth in the "Pirate's Treasure" level, and have come across what appears to be a well-known glitch. The final bit of the level has you jumping between two flaming wooden poles, with the right-hand one eventually collapsing, allowing you to advance:

What constantly happened to me, though (and to quite a few others), is that once the pole collapses the screen pans right too quickly and kills you:

I did eventually manage to get the tooth, after at least 20 attempts, but I'd be damned if I know what I did differently. I did try all sorts of suggestions, but none of them did the trick. When I did finally manage, the screen passed over me but not fast enough to get me killed, so with a few lucky jumps I managed to get back in the frame and get the tooth.

So, does anyone have a verified way to get through this level successfully?

share|improve this question
add comment

1 Answer

Yea I absolutely hate this!!! I finally got it just now after at least 15 attempts, most of which ended at this precise point. Although most people claim it's a glitch, I don't believe it is.

In all of my failed runs, I held the jump button down in between the walls (to maximize the height of my jump). I succeeded by ditching this idea, and instead, in order to go as fast as I could, I quickly tapped (and released) the jump button. This made all the difference, and I was able to replicate the results twice more.

share|improve this answer
    
Sounds good. I'll award you the answer once I try it out myself. –  Aubergine Mar 26 '12 at 6:18
    
I tried this out yesterday, but I'm either doing it wrong, or it's not working for me. I'll be glad to award you with the answer all the same assuming anyone else can corroborate this. –  Aubergine Apr 2 '12 at 6:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.