Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've been running a Minecraft server for a while and never had any problems with server upgrades before, up to and including version 1.1. Now I'm testing 1.2.x, and although I always spawn in the location where my home used to be, the world there is completely different. What am I missing?

share|improve this question
3  
It's a bit weird. Are you running a vanilla server or a bukkit one? –  Allov Mar 24 '12 at 16:45
    
Vanilla. I'm trying to avoid using bukkit if possible. Although I'm starting to understand why most server admins have given up and are running bukkit. Why are the vanilla server tools so awful/nonexistent? –  boot13 Mar 24 '12 at 18:36
    
Well, because Minecraft doesn't support mods as is. Bukkit and MCP are possible because Java is somewhat decompilable and mods and other tools can be added. However, this doesn't explain why your map is "resetting". When you update Minecraft, do you overwrite the file in the same directory, or you start over in a new one? –  Allov Mar 24 '12 at 18:53
    
I just plop the new server JAR into the same folder. If I put it in a new folder, presumably I would then also need to copy the 'world' subfolder from the old folder to the new one, right? –  boot13 Mar 24 '12 at 19:05
    
Yeah, that's what you would have to do. I don't really know what's going on. Maybe you could try loading your map with MCEdit and see if it's not just a matter of spawn point acting funny. –  Allov Mar 25 '12 at 16:27
show 9 more comments

1 Answer 1

up vote 1 down vote accepted

Resolved. Here's what I did: Copied the 'world' folder from the server folder to single player 'saves' folder. Opened the world from the 'saves' folder in MCEdit. Opened the 'World Info' dialog in MCEdit (Ctrl-I), then ran the 'Repair regions' tool. Saved the world. Ran the most recent Minecraft client, and the world appeared in the world list, but said that it needed to be converted. Opened the world in single player mode from there and it converted, saying 'Converting to Anvil'. Copied the world back to the server folder and ran it in multiplayer mode. Everything was back to normal!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.