Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm pretty new to Minecraft having only just bought the game about a week ago, so apologies if I'm missing something obvious here (I've attempted to search for the answer, but didn't find any relevant results)

I've got a private minecraft server on my home network in survival mode with spawn-monsters disabled and normal difficulty, I've not seen any hostiles, or at least not until just now. I've just found a location in the world, deep underground, where I've found what was a fully enclosed pitch black room that was full of zombies. I got overwhelmed by them within seconds, but I did briefly notice a number of storage chests and other items within the room.

If it is relevant, I found the room by accident when I saw my first moss cobblestone. Not knowing exactly what the block was, I mined them thinking I'd found another resource, in doing so, this room was revealed.

I'm the only person that has played on the server (it's behind a firewall, and I stop and start the server on demand).

Is there any explanation for this? I didn't expect to see any hostiles at all with spawn-monsters option disabled. I'm going to head back as soon as I get chance, but was wondering what it might be?

share|improve this question
add comment

3 Answers

up vote 21 down vote accepted

You found a Dungeon. These contain Monster Spawners.

The spawn-monsters multiplayer option in the server's config file only controls natural, random monster spawns in dark areas. Unless the server difficulty is also set to Peaceful (or 0), Monster Spawners will still be active if you go near them.

share|improve this answer
2  
I think typing /gamerule doMobSpawning false will disable all mob spawns. You must be OP to type this command. This is not in your server.properties file. –  Timtech Jul 26 '13 at 22:07
add comment

What you've found is a Dungeon. Specifically, a Zombie dungeon. It contains a Monster Spawner which is able to spawn monsters even if spawn-monsters is disabled. The only way to stop a spawner from spawning monsters, is to fully light up the area, or set the server to peaceful.

share|improve this answer
    
+1; Many thanks. Perfectly good answer, but I can only accept one, which I did based upon response time. –  Bryan Mar 26 '12 at 13:49
add comment

That is called a dungeon. It contains a mob spawner mossy cobble and chests. The spawn-monster command can't stop this.

share|improve this answer
1  
So what're you adding to last year's answers? –  Zommuter Aug 7 '13 at 13:11
3  
(I didn't mean to be rude, but there's plenty of unanswered questions you could answer instead of rephrasing existing answers, intentionally or not) –  Zommuter Aug 7 '13 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.