Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

A lot of people seem to be having problems with Minecraft using too much CPU power. I wish for my Minecraft to use more CPU that it does now.

Some Info: I have a dv7 laptop with an i5 quad core 2.4 gHz chip, 6 GB of RAM, and a Radeon HD 6770 graphics card. Basically, this computer is quite the beast. It can play Eve and other high-tech games. But it plays Minecraft slower than my brother's computer, which is dual core and equipped with a low-end graphics card. I asked him to open his task manager and found he was using 60%, if not more, of his CPU to play Minecraft, exceeding his performance.

Question: How do I enable my CPU to use all its cores and CPU power on Minecraft?

Another question I would also have would be, why is my brother's computer playing it faster? It kinda pisses me off.

share|improve this question
2  
What version of the Java Runtime Environment are you using? How about your brother? This may be a problem with Minecraft not parallelizing well, but it may also be a problem with your JRE version –  Dave McClelland Mar 27 '12 at 17:37
    
Assuming it's running at normal priority, on high settings, and you don't have much going on in the background while you play: There's nothing you can do. You can make Minecraft do more with the CPU than it's programmed to do. If there's actually a problem preventing it from using more system resources we would need more info to help you fix it. –  Matthew Read Mar 27 '12 at 17:47
1  
I have the newest version of the JRE and my brother does too. –  parion Mar 27 '12 at 18:21
    
I'm assuming you're running with High Performance in your Power Settings applet? For laptops, that setting is pretty important as it can and will throttle your CPU (even on Balanced). –  Brandon Mar 27 '12 at 19:20
5  
New computer =/= latest drivers. –  kotekzot Mar 29 '12 at 20:54
show 7 more comments

4 Answers

up vote 6 down vote accepted

(Unmodded) Minecraft isn't multithreaded, so splitting it across multiple CPUs is not possible. However, I am not sure about a mod to allow for this possibility. There might be other factors you are ruling out.

From what I have found the mod, OptiFine, is supposed to split the load across two cores. (Otherwise, Minecraft only uses one)

OptiFine 1.2.4 Mod adds a lot of options for better looks and performance. Doubling the FPS is common. Moves fog away, adds mipmaps, chunk loading control (mod CAF), Smooth FPS, brightness control, VSync and many other.

Screenshot of Optifine below: enter image description here

share|improve this answer
    
I had OptiFine Mod. It doesn't help at all, even makes it a little slower at times. –  parion Mar 27 '12 at 18:19
    
"..supposed to.." –  Zero Stack Mar 27 '12 at 18:59
3  
Looks like that's that, then. Minecraft cannot take advantage of your additional cores. Your brother's computer must have more processing power per CPU core than yours. Quad cores don't provide much benefit for most consumer applications. –  kotekzot Mar 27 '12 at 19:19
    
Hmmm alright. A shame really. I can't bear knowing his 2-year-old computer is faster than mine. :/ –  parion Mar 27 '12 at 19:38
    
That's where an i7 or higher family chip would have been better as they will shut down additional cores and overclock a single core if there isn't any usage on those additional cores. –  Brandon Mar 29 '12 at 23:01
show 1 more comment

Have you checked options/video settings? There is an option for "Power saver / Balanced / Vsync / Max FPS" modes. Setting that to Max FPS might solve your problem.

There is really no way to make Minecraft use your multiple cores more efficiently, because Minecraft doesn't handle multi-threading as well as some other games might. It might even run faster on an older, dual-core CPU such as your brother's.

Also, if installing mods isn't an issue, you could try out OptiFine, which generally helps with low FPS issues (and it also has a ton of other useful features).

share|improve this answer
    
I have Max FPS on. And I had Optifine and it doesn't help. –  parion Mar 27 '12 at 18:20
add comment

The fix for my performance issues was using the 64 bit version of the Java runtime. After that was installed Minecraft ran much better.

64-bit Java can be downloaded here: http://www.java.com/en/download/manual.jsp

To my understanding, the 64-bit Java runtime only gives Minecraft access to more RAM. Yet this fixed the performance issue.

share|improve this answer
add comment

I installed ThrottleStop and gave Minecraft a higher FID (in my case, 10 instead of 6).

Now Minecraft uses the full 2.5GHz of my processor instead of capping at 800MHz or so. It runs smooth as butter.

A word of warning, however: if you're using a laptops, you do want to keep an eye on the heat situation before the computer shuts off on you.

share|improve this answer
add comment

protected by Community Oct 11 '12 at 20:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.