Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am having difficulty running a game using DOSBox. The problem begins after I begin the installation. It runs through fine, until it asks which drive I would like to copy the files to. It only shows Z, but not the mounted drive I selected (say H) for my DOS games directory.

My only choice is to select the Z drive, however it the tells me that it does not have enough space for the copies. This is ultimately the issue.

The exact error message is: "The drive you have selected does not have enough free space to install The 7th Guest. Please select another drive or exit and increase the free space on this drive".

There is also a second box on the right saying: "Space Remaining On Drive: < 5 Thousand Bytes."

Prior to that, is a screen asking me to select a drive. The only drive on the list is "Z:".

Is it possible to increase the size of the Z drive that DOSBox automatically creates? Or, is there a way of using the drive I mounted? It does not appear on the "Select Hard Drive" inside the installation.

I have considered compiling it from source, and taking a look at the code seeing if I can hack it. Of course, that is only if there is no easier solution.

I am trying to run The 7th Guest, a fantastic puzzle game. I am running DOSBox on Linux, Ubuntu 11.10 to be exact. The version of DOSBox I am running is 0.74.

share|improve this question
    
do you happen to have seen The 7th Guest at gog.com and dug out your old CDs? –  Zommuter Apr 2 '12 at 21:17
    
If your machine is not too old, you might want to consider using a virtual machine (e.g. VirtualBox or VMWare Player) together with either your old MS-DOS or something like FreeDOS. If your machine is too old to run that smoothly, it might be possible to install DOS to boot from a USB key. Or in GRUB, see here –  Zommuter Apr 2 '12 at 21:22
    
@Zommuter I fail to see the relevance of your reply. In light of your second reply, I will consider trying that if I only get to that sort of state in temptation. –  Mark Apr 3 '12 at 1:40
    
try using a DosBOX frontend like Dfend Reloaded if you still haven't got this working. –  warsong Jul 8 '12 at 11:36

2 Answers 2

I'm going to try to answer generally, since I don't have this game.

Some games expect you to have C:\ since probably 99% of Windows/DOS installations use that as their main drive. So try (for example):

mount C /home/user/oldgames

And then run the installer and try installing it under C.

If your path is something like /media/external then it could be that the drive is too big, and the installer thinks the drive size is a negative value or something due to integer overflow. In that case you could try making a small partition and using that instead. This is assuming DOSBox uses the max available size. You can specify a size (in MB) like so:

mount C /path/to/whatever -freesize 1024
share|improve this answer
    
I tried mounting the drive using "C" as the drive letter. It still did not list the mounted drive apart from "Z". I also tried what you mentioned below, and I got the same result. I would say it is because of the emulation, but it picks up the virtual drive that DOSBox uses. –  Mark Apr 2 '12 at 18:33
    
@Mark Hmm, interesting. Where is the installer located? –  Matthew Read Apr 2 '12 at 18:35
    
The files are located on the Linux filesystem. When I mount this location in DOSBox, I type in "INSTALL.BAT", which runs a program called "INSTALL.EXE" in "T7G/INSTALL". I also tried creating an ISO out of these files, and mounting that ISO as a virtual disc inside DOSBox. No difference sadly. –  Mark Apr 2 '12 at 18:47
1  
@Mark Hmm, if you're not already maybe do something like put the files in /path/to/install, run mount C /path/to, and try to install to /path/to/game or something so they share the same root. I'd also experiment with running DOSBox with su privileges. –  Matthew Read Apr 2 '12 at 19:06
    
I shall try that later, and get back to you. Thank you! –  Mark Apr 2 '12 at 19:13

Some games refuse to install to what it thinks is not a physical hard disk (like a network share, or removable media). DOSBOX mounts are faux-network shares to simplify management, but you can create a hard disk image that the game should accept as a valid destination:

http://www.dosbox.com/wiki/IMGMOUNT

This allows you to mount a disk image file as a hard disk. It's a bit more complicated than simply cross-mounting your host filesystem, but once set up it's indistinguishable from a hard disk to the hosted software.

share|improve this answer
    
I tried this earlier, but I tried it again. It still only shows drive "Z" as the only available hard drive. –  Mark Apr 3 '12 at 2:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.