Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have the latest dash, but when I insert an original xbox disk (confirmed on wiki to be compatible) I just get an error to install additional software without any option or instruction as to what this software is.

The games were Fable: The lost chapters and GTA: Vice city. They were undamaged. Both show up on the List of Xbox games compatible with Xbox 360 wikipedia page. I have plenty of space on my 250GB hard drive.

share|improve this question
    
what game is it? is the disk damaged? can you try another xbox disk? did you confirm that it is OFFICIALLY compatible? –  KiloJKilo Apr 15 '12 at 18:17
    
@KiloJKilo, updated with the information requested –  Bob Roberts Apr 15 '12 at 20:56
    
Do you have a Hard Drive, or are you using memory unit for saving? –  APrough Apr 27 '12 at 17:05
    
@APrough, I am using a 250GB drive –  Bob Roberts Apr 30 '12 at 14:08
    
How is the network that you're trying to connect with setup? –  FCTW Jun 3 '12 at 3:35
show 2 more comments

1 Answer

You could try downloading the compatibility pack here. I don't remember having to do this, I think it auto updated but that was years ago and maybe since the newer releases it wasn't something that was overtly needed so they didn't provide it automatically.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.