Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I only titled this "Certain PC Game Views Always Moves UP!" because I didn't know what else to ask.

Here's the problem, I've tried installing Borderlands & Singularity & gotten the same problem with both games, (if I can explain this correctly) the "view" of the 1st person character (myself) ALWAYS moves to the top of the screen. As if you've moved your mouse up so that your looking straight into the sky. Whenever you move the mouse down, (effecting the view of your character) the view of said character moves directly back to the sky.

It's not the easiest question for me to put into words. I've done a LOT of research on-line & found not one other person with this issue. I'm probably explaining it wrong.

Any help would be appreciated.

AMD Athlon 64 X2 5000+ 2.6GHz 2GB DDR2 Radeon HD4350 Catalyst 10.7 500GB HD 75% Full Windows 7 Ultimate

Anything else needed to know please ask.

EDIT I also have a Microsoft wireless mouse with the IntelliPoint driver & Logitech wireless keyboard & mouse combo with the SetPoint driver & Xbox 360 controller & driver & Xpadder 5.7 for those games that don't support joypads.

I've tried EVERY combination of ON-OFF diver-mouse-xpadder-no xpadder but it ALWAYS ends up with the exact same video issue.

Every other game plays fine. COD MW 1 & 2, Farcry 2, Fallout 3, LEGO Indy 2, etc etc etc

BTW, I know my machine isn't a "gaming rig", every other game works fine. If these two do the exact same thing than I know there will be more.

share|improve this question
    
I had this problem with Borderlands and when I unplugged my DDR mat it started working fine. Try disabling all third-party controllers and play with mouse+keyboard. –  StrixVaria Aug 26 '10 at 12:54
1  
Is "Look up" an action that is bound to a key? What key is it? Have you tried tapping it? –  badp Aug 26 '10 at 13:04
add comment

2 Answers

up vote 10 down vote accepted

The two games you mentioned (Borderlands and Singularity) have in common that they both run on the Unreal Engine 3 (as opposed to the other games you gave as example).

This engine is the most used for current games, so it's very unlikely to have a graphical problem related to an incompatible brand.

The issue you describe looks like someone is forcing you to watch up all the time, nothing else. The interesting point is that the UE3, being ported to consoles, has a native gamepad support, which means that most games based on it will be able to use the gamepad, even if you would expect them to only use mouse, being shooter games.

The issue in this case is most likely that your specific drivers for the gamepad are badly configured for this engine, and one axis is considered pressed all the time, making you look up all the time.

I suggest you try one of the following:

  • Tweak your xpadder to see if it's not activating an axis all the time
  • Unplug your gamepad and deactivate its driver
  • Change the control options in the games, the gamepad ones.
share|improve this answer
2  
+1, even if solution doesn't work at least you provided a good starting point :) –  Josh K Aug 26 '10 at 12:58
    
I have finally found the solution to this issue & yes, Gnoupi, you were right. I had to disconnect the gamepad that I initially hooked up (ps2 to xbox converter box spliced with a USB wire to run a ps2 controller through Xpadder)...once I used an actual Xbox 360 controller with correct drivers & ran in XP3 compatibility mode everything works perfect. Thank you! –  comet.vermont Oct 7 '10 at 23:20
add comment

A lot of games work by rapidly moving your mouse to the center of the screen. Each time it moves the mouse to the center, it takes your currently location relative to the center as the distance you moved your mouse during the last iteration.

If for some reason the game is unable to make your cursor jump back to the center, any small bit of movement away from the center of the screen will make the game continually move in that direction which means if your cursor is anywhere above the center line you will end up looking at the sky in no time flat. If it is left or right of center too you will probably have a spinning view of the sky. You should be able to get a spinning view of your feet too if this is the issue by moving your mouse down.

share|improve this answer
    
You may need to run the game as administrator to fix this. –  John Gietzen Aug 26 '10 at 15:16
    
The spinning sky & feet issue is exactly whats happening Dan. So far you are the first person that has given me any in site to the issue. NOW, how can it be fixed? –  comet.vermont Aug 26 '10 at 15:52
    
@comet: I've run into this issue before when trying to emulate games in wine or run them on virtual operating systems that didn't have control of the mouse, never with an actual OS. For some reason the game doesn't have control over your mouse. Try John's suggestion of running the game as administrator. Also, you can try right clicking the exe file and under "compatibility" try different settings to see if that helps at all. –  Dan Aug 30 '10 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.